erreur fichier

milomech

XLDnaute Junior
dans mon fichier je n'arrive pas a faire apparaitre debit credit quand je clique sur enregistrer une opération dans la feuille recap. quelqu'un peut m'aider?
 

Fichiers joints

bqtr

XLDnaute Accro
Re : erreur fichier

Bonjour milomech,

Si je comprends bien tu veux lancer ton userform quand tu click sur ton bouton.

Fait un click droit dessus, choisis affecter une macro, dans la liste des macros qui s'affiche sélectionne : Zonedetexte1_QuandClic et ok

Bonne journée
 

milomech

XLDnaute Junior
Re : erreur fichier

ce n'est pas ca, qd je clic sur enregistrer opération j'ai un fenetre qui s'ouvre, dans la ligne credit debit je pouvai choisir credit ou debit. la rien ne saffiche et quand on fait valider on me di que que je n'ai pas selectionner debit ou credit.Comment je peux faire pour avoir de nvx ce choix.

merci
 

bqtr

XLDnaute Accro
Re : erreur fichier

Re,

Dans ton fichier il n'y a rien qui correspond à ce que tu décris "Débit/Crédit" ?
Donc j'ai fait ca : regarde si cela te convient :

Quand tu click sur le bouton un Userform s'ouvre et la tu sélectionnes Débit ou Crédit dans le combobox.
Tu valides et l'userform de saisie s'ouvre et la listbox mode sélectionne automatiquement le résultat de la combobox.

Voilà, Si c'est une inputbox que tu souhaites c'est pas compliqué à faire, mais il faudra préciser ce que tu veux faire avec son résultat.

bonne soirée
 

Fichiers joints

milomech

XLDnaute Junior
Re : erreur fichier

merci bcp c'est tt a fait ca.
T'es un as merci

si j'ai d'autre question je pourrai me tourner vers toi?

bonne soirée
 

milomech

XLDnaute Junior
Re : erreur fichier

jai un petit pb, je souhaiterai créer une colonne cumul dans la feuille caisse
pour la premiere ligne de cumul sa serai somme au 7mars 2007+valeur de credit - valeur du débit.

A la seconde ligne du cumul = premier ligne du cumul + credit - debit.

il y aurai donc une fonction sur la celule debit credit.

je c pa si c clair


merci
 

Fichiers joints

bqtr

XLDnaute Accro
Re : erreur fichier

Re,

Une solution par formule.

Formule à mettre en G5 :
Code:
=SI(D5="";"";SI(D5="Débit";C2-F5;C2+F5))
Formule à mettre en G6 et à recopier jusqu'à la ligne 448 :
Code:
=SI(D6="";"";SI(D6="Débit";G5-F6;G5+F6))
Bonne fin de soirée

Edit : je viens de voir que tu avais déjà des réponses sur un autre fil ????
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas