Office 365 Déplacer des cellules sur une autre feuille du même classeur

matthieube

XLDnaute Nouveau
Bonjour à tous!!

Je souhaite décaler des cellules sur une autre feuille d’un même classeur sans que ça ait un impact sur l’ensemble des calculs et liaison.
J’ai sélectionné les cellules puis cliquer sur alt et fait glisser tout ça sur une autre feuille mais ça a un impact. Les calculs et liaisons ne sont pas conservés.
On le voit d’ailleurs assez simplement quand on fait une sommes de 5 cellules et qu’on choisi ensuite de décaler une de ces cellules ailleurs le total ne prend plus en compte la cellule décalée.

Avez vous une solution possible s’il vous plaît?

Merci beaucoup!!!
 

Dudu2

XLDnaute Impliqué
Bonjour,
Pourquoi fais-tu un Glisser / Déposer ?
Un simple Copier / Coller ne fonctionne pas ?
D.
 

job75

XLDnaute Barbatruc
Bonsoir matthieub, bienvenue sur XLD, hello Dudu2,

Rien compris, sans fichier joint je n'irai pas plus loin.

A+
 

Patrice33740

XLDnaute Occasionnel
Je souhaite décaler des cellules sur une autre feuille d’un même classeur sans que ça ait un impact sur l’ensemble des calculs et liaison.
J’ai sélectionné les cellules puis cliquer sur alt et fait glisser tout ça sur une autre feuille mais ça a un impact. Les calculs et liaisons ne sont pas conservés.
On le voit d’ailleurs assez simplement quand on fait une sommes de 5 cellules et qu’on choisi ensuite de décaler une de ces cellules ailleurs le total ne prend plus en compte la cellule décalée.
Avez vous une solution possible s’il vous plaît?
Effectivement, pour que ça fonctionne il ne faut pas que les cellules déplacées se trouvent à l'intérieur d'une plage qui sert à un calcul.
Par exemple si tu as SOMME(A1:A20) et que déplaces A5:A10 vers B5:B10, la formule restera la même. Il n'y a pas de solution automatique pour que la formule devienne =SOMME(A1:A4;B5:B10;A11:A20)
Il faudrait avoir au départ =SOMME(A1:A4;A5:A10;A11:A20)
 

matthieube

XLDnaute Nouveau
Exactement Patrice c'est mon problème. Les cellules que je souhaite déplacer sont liées à d'autres formules dans d'autres cellules. Je trouve ça dommage. Excel est un outil puissant mais trouve sa limite sur une demande assez simple finalement...
 

Patrice33740

XLDnaute Occasionnel
Le cas que tu présente n'est pas très courant.
En général on déplace l'ensemble des cellules de la plage calculée (ex: A1:A20) et comme je t'ai dis si tu sais que tu va en déplacer seulement une partie, il suffit de prévoir les formules en conséquence (ex: =SOMME(A1:A4;A5:A10;A11:A20) ).
 

job75

XLDnaute Barbatruc
Bonjour,

Perso je trouve ça très bien que SOMME(A1:A20) ne compte plus les cellules déplacées.

Les limites d'Excel ne peuvent pas s'adapter à tous les goûts et couleurs :rolleyes:

A+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas