XL 2016 Dates pour plan de charge

Julio@77

XLDnaute Nouveau
Bonjour,

Après avoir longuement réfléchis, je me tourne vers vous pour votre précieuse aide ! :)

- Ci-joint le fichier excel en question -

C'est assez rapide à comprendre.

Problème de formule étirée ligne 4 :
Aujourd'hui nous sommes vendredi, je vois S-1, je souhaiterais voir S0.
D'après la formule, jusqu'au jeudi de chaque semaine, je peux observer S0 et non S-1

Formule - cellule B4 = =SI(B3-AUJOURDHUI()+JOURSEM(AUJOURDHUI())<0;"Passé";SI(B3-AUJOURDHUI()<5*24+1;"S"&ARRONDI((B3-AUJOURDHUI())/7;0);"Futur"))
 

Fichiers joints

Julio@77

XLDnaute Nouveau
Bonsoir,
Merci pour votre aide.
Mais après analyse approfondie, je ne vois aucune modification...

J'étais pas très bien réveillé hier soir hehe...

Julio
 
Dernière édition:

Julio@77

XLDnaute Nouveau
Bonjour,

Voici ce que j'observe concernant les formules :
Ancien : =SI(C3-AUJOURDHUI()+JOURSEM(AUJOURDHUI())<0;"Passé";SI(C3-AUJOURDHUI()<5*24+1;"S"&ARRONDI((C3-AUJOURDHUI())/7;0);"Futur"))

Nouveau :=SI(C3-AUJOURDHUI()+JOURSEM(AUJOURDHUI())<0;"Passé";SI(C3-AUJOURDHUI()<5*24+1;"S"&ARRONDI((C3-AUJOURDHUI())/7;0);"Futur"))

Peut-être n'est-ce pas à ce niveau que vous avez modifié quoique ce soit ?!

D'avance merci pour votre aide,

Julio
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je n'ai rien modifié dans la formule, j'ai seulement calculé la date en ligne 3 avec cette formule.
VB:
=DATE(A$1;1;3)-JOURSEM(DATE(A$1;1;3))-5+(7*A$2)
JHA
 

Julio@77

XLDnaute Nouveau
Bonjour @JHA ,

Tout d'abord merci pour votre aide et votre temps mais cela ne change pas la donnée de la ligne 4, à savoir "Passé" ou "S+x"

1575023174889.png

Nous sommes vendredi 29 de la semaine 48 et je vois S-1 alors que je souhaiterais voir S0 jusqu'à dimanche.

Merci d'avance pour vos retours,

Julio
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas