XL 2010 Calcul nb heures ouvrées entre 2 dates différentes

friends__59

XLDnaute Nouveau
Bonjour à tous,

Voici ma problématique je dois calculer le nombre d'heures ouvrées entre une demande et une réponse, il peut se passer 1 ou plusieurs jours entre les 2. Les horaires ouvrés pour 1 journée type sont 9h-12h et 14h-18h soit 7h. Sachant que si la demande se fait avant 12h il ne faut pas oublier de déduire les 2h de pause déjeuner. Si la demande se fait après 18h on ne compte les heures qu'à partir du lendemain 9h. J'avoue que je sèche un peu.

Voici un fichier avec 2 -3 exemples.

J'espère être compréhensible. Merci pour votre aide.
 

Fichiers joints

njhub

XLDnaute Nouveau
Bonjour à tous,

Voici ma problématique je dois calculer le nombre d'heures ouvrées entre une demande et une réponse, il peut se passer 1 ou plusieurs jours entre les 2. Les horaires ouvrés pour 1 journée type sont 9h-12h et 14h-18h soit 7h. Sachant que si la demande se fait avant 12h il ne faut pas oublier de déduire les 2h de pause déjeuner. Si la demande se fait après 18h on ne compte les heures qu'à partir du lendemain 9h. J'avoue que je sèche un peu.

Voici un fichier avec 2 -3 exemples.

J'espère être compréhensible. Merci pour votre aide.
Bonjour friends__59,

Voyez si le fichier joint peut vous aider
Code:
=SOMME((C2-SI(B2>=18/24;A2+1;A2))*7/24;MOD((C2+SI(D2>=14/24;D2-2/24;D2))-(A2+SI(OU(B2>=18/24;B2<9/24);9/24;SI(ET(B2>1/2;B2<=14/24);14/24;B2)));1))
 

Fichiers joints

tatiak

XLDnaute Barbatruc
Bonjour à tous,

Il se peut que ça puisse répondre à la question (?) :

Juste une démo de calcul en fonction d'heures ouvrées (et fériés FR). 2 modes de calculs :

* une date-heure de fin à partir d'une date-heure de début (A) et d'une durée en heures (B)

* une durée à partir d'une date-heure de début (F) et d'une date-heure de fin (G)

Les résultats sont en fonction des horaires de travail indiqués en "Cfg" (matin/aprèm sur 7 jours, vide si repos)

Les 2 fonctions utilisées sont récursives.

Avec mes tests, il me semble que le compte est bon ...
Pierre
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas