XL 2016 Additionner les X cellules suivantes

zephoenix

XLDnaute Nouveau
Bonjour à tous les experts

Je suis devant une colle et j'ai besoin de votre aide pour m'en sortir.

J'ai une liste de 3000 matchs structurés bizarrement et ventilés sur plusieurs jours sur mon tableur avec un nombre de joueurs par match.
J'ai besoin de réaliser une somme du nombre de joueurs qui ont joué par jour.
Donc en fonction du nombre de matchs joués dans la journée, j'ai besoin de demander à Excel de me faire l'addition des X cellules suivantes. Le X étant le nombre de matchs joués dans la journée.

J'ai mis un extrait de mon fichier à disposition.

Merci d'avance pour le temps et l'aide que vous voudriez m'apporter.

Bonne journée

Christophe
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
Bonsoir.
Pour le faire tel que vous le dites, en E2 :
Code:
=SOMME(DECALER($C$2;1;0;$B$1;1))
En E14 :
Code:
=SOMME(DECALER($C$13;1;0;$B$13;1))
En E20 :
Code:
=SOMME(DECALER($C$19;1;0;$B$19;1))
Mais je ne comprends pas trop pourquoi vous avez besoin de le faire comme ça.
 
Dernière édition:

zephoenix

XLDnaute Nouveau
Bonsoir Dranreb

Merci pour votre solution.
En fait je n'ai pas trop le choix car j'ai réceptionne le fichier tel quel.
Je veux bien essayer de le travailler pour qu'il soit fait différemment mais je ne sais pas trop ce que je dois faire pour que cela m'aide.

Comme j'ai environ 380 jours je cherchais une formule que je puisse descendre sur toute ma colonne.

Merci encore

Bonne soirée

Christophe
 

Dranreb

XLDnaute Barbatruc
Si vous acceptiez une colonne F supplémentaire et d'avoir les totaux à la fin, vous pourriez faire :
En F3 :
Code:
1
En F4, à propager sur 23 lignes :
Code:
=SI(ESTVIDE($C4);"";SI(ESTVIDE(DECALER($C4;-1;0));1;DECALER(F4;-1;0)+1))
En E3, à propager sur 24 lignes :
Code:
=SI(ESTVIDE(DECALER($C3;1;0));SOMME(DECALER($C3;-$F3;0):$C3);"")
 

zephoenix

XLDnaute Nouveau
En fait c'est exactement ça que je voulais !!
Merci beaucoup
Il me fallait ce gros coup de mains pour que ça aille tout seul
Vraiment merci beaucoup de votre aide et de votre patience.

Bonne nuit Dranreb
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas