Additionner les cellules de la même année

Sissou71

XLDnaute Occasionnel
Bonjour,

Je dois faire des calculs sur l'année civile dans un fichier Excel.
Dans mon fichier j'ai plusieurs années et la 1ere référence peut ne pas commencer au 1er janvier (fichier joint).

Je souhaiterai additionner toutes les valeurs qui ont la même année au fur et à mesure.

Merci pour votre aide
 

Fichiers joints

Dugenou

XLDnaute Barbatruc
Re : Additionner les cellules de la même année

Bonjour,
en D4 et à recopier vers le bas :
Code:
=SOMMEPROD((ANNEE($A$4:A4)=ANNEE(A4))*$C$4:C4)/SOMMEPROD((ANNEE($A$4:A4)=ANNEE(A4))*$B$4:B4)
Cordialement
 

Sissou71

XLDnaute Occasionnel
Re : Additionner les cellules de la même année

Merci beaucoup effectivement j'étais partie avec des somme.si donc pas dans la bonne direction !

Cordialement
 

Dugenou

XLDnaute Barbatruc
Re : Additionner les cellules de la même année

Oui, le somme.si n'aime pas l'utilisation de fonctions dans la zone plage : il aurait fallu utiliser une colonne supplémentaire avec seulement l'année ou faire un calcul à partir de la date en colonne A pour avoir le début et la fin de l'année et faire un somme.si.ens (si vous avez la bonne version d'excel):
Code:
=SOMME.SI.ENS($C$4:C4;$A$4:A4;">="&DATE(ANNEE(A4);1;1);$A$4:A4;"<="&DATE(ANNEE(A4);12;31))/SOMME.SI.ENS($B$4:B4;$A$4:A4;">="&DATE(ANNEE(A4);1;1);$A$4:A4;"<="&DATE(ANNEE(A4);12;31))
donc un peu moins concis...
Cordialement
 

Sissou71

XLDnaute Occasionnel
Re : Additionner les cellules de la même année

Oui merci beaucoup le sommeprod me convient parfaitement.
Cordialement
 

JM27

XLDnaute Impliqué
Re : Additionner les cellules de la même année

Bonjour
Par un TCD avec un champ calculé

nota: on peut créer un champ dynamique en cas d'agrandissement du tableau.
 

Fichiers joints

Dernière édition par un modérateur:

Sissou71

XLDnaute Occasionnel
Re : Additionner les cellules de la même année

Merci JM27

Je garde le sommeprod pour mon besoin actuel, les utilisateurs ne voulant pas de TCD dans leur utilisation.
 

Discussions similaires


Haut Bas