Transcrire infos adjacentes à une colonne, selon une liste déroulante

valeriemp

XLDnaute Nouveau
Bonjour à tous, futurs sauveurs,

J'ai présentement un fichier dans lequel j'ai une liste de titres d'émissions (A7 à A29), qui ont chacune d'elles des chiffres adjacents (B7:K29). Plus bas, j'ai une case avec liste déroulante (A33).

Je voudrais que lorsque la personne choisit une émission dans la liste déroulante (A33), les données adjacentes à l'émission en question (exemple, émission en A10, données B10 à K10) se retranscrivent à côté du choix de la liste déroulante (B33 à K33).

*Pour votre info, la liste dans le document ci-joint est réduite au 1/8 du nombre d'émissions que j'ai vraiment.

Je vous joins mon document. Un énorme merci pour votre aide!

Valérie
 

Fichiers joints

chris

XLDnaute Barbatruc
Re : Transcrire infos adjacentes à une colonne, selon une liste déroulante

Bonjour et bienvenue

En B33, puis à recopier sur les cellules à coté :
Code:
=RECHERCHEV($A33;$A$6:$K$29;COLONNE();0)
 

valeriemp

XLDnaute Nouveau
Re : Transcrire infos adjacentes à une colonne, selon une liste déroulante

Un énorme merci Chris! Ça fonctionne très bien! Pour reprendre ta signature «Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson», j'aimerais décortiquer un peu cette formule. J'aime bien pouvoir comprendre les choses pour pouvoir les assimiler plus facilement.

Donc, je comprends que cette fonction me permet de rechercher ce à quoi A33 est équivalent. Ensuite, vous me perdez. J'essaie de comprendre la portion A6:K29;COLONNE();0)

Serait-ce possible de me la traduire svp :)

Valérie
 

chris

XLDnaute Barbatruc
Re : Transcrire infos adjacentes à une colonne, selon une liste déroulante

RE

A6:K29 c'est la plage où on cherche. RECHERCHEV en parcourt verticalement la 1ère colonne et peux récupérer les infos des autres colonnes.

Comme tu souhaites la colonne B de cette plage dans la colonne B, C dans la C etc, Colonne(), indique même colonne de A6:K29 que celle de la formule

0 pour une recherche exacte et non approximative.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas