Résolu Somme sous conditions

momo

XLDnaute Occasionnel
Bonjour à tous

Je voudrais faire une somme sous une condition donnée

Condition: faire l'addition des écarts supérieurs à 0 (Différence positive)

J'ai joins un fichier qui montre les résultats attendus

Merci d'avance
 

Fichiers joints

momo

XLDnaute Occasionnel
Bonjour JHA

Merci pour cette solution qui marche.. Par contre est ce qu'il est possible, de compartimenter en fonction de la colonne année

Ceci a cause de plages qui pourraient dynamique (Nombre de ligne pouvant augmenter)
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer:
VB:
=SOMME(SI(DECALER(C1;EQUIV(2017;C2:C9;0);-1;4)<DECALER(C1;EQUIV(2018;C2:C9;0);-1;4);(DECALER(C1;EQUIV(2018;C2:C9;0);-1;4)-DECALER(C1;EQUIV(2017;C2:C9;0);-1;4))))
Formule matricielle

JHA
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas