[RESOLU] : VBA compter nombre cellule non vide dans une plage

MADAGASCAR

XLDnaute Occasionnel
Bonsoir EXCEL DOWNLOADS
Bonsoir chers membres
Si vous pouvez m'aider svp de comprendre comment compter le nombre de cellule non vide dans une plage precise comme exemple A3:A100 ..avec macro VBA
Merci beaucoup d'avance pour l'aide
Cordialement
MADA BLACK
 
Dernière édition:

excfl

XLDnaute Accro
Re : VBA compter nombre cellule non vide dans une plage

Bonsoir le forum,

En attendant la solution en VBA :

Code:
=SOMMEPROD((A1:A100<>"")*1)
 

MADAGASCAR

XLDnaute Occasionnel
Re : VBA compter nombre cellule non vide dans une plage

Bonsoir excfl
Bonsoir Modeste geedee
La formule d'excfl ..Le code de Modeste geedee .. les deux suggestions me donnent resultat exacte ..soit par formule ou par le msgbox
Merci beaucoup a vous deux
Cordialement
MADA BLACK
 

Modeste geedee

XLDnaute Barbatruc
Re : VBA compter nombre cellule non vide dans une plage

Bonsour®
Bonsoir excfl
Bonsoir Modeste geedee
La formule d'excfl ..Le code de Modeste geedee .. les deux suggestions me donnent resultat exacte ..soit par formule ou par le msgbox
Merci beaucoup a vous deux
Cordialement
MADA BLACK
;)
Ouf ! comme disais Magic-Doctor http://www.excel-downloads.com/forum/235448-calculer-toutes-les-sommes-possibles-dune-liste-de-nombres-post1506163.html#post1506163
j'ai eu peur ...

je suis bien content que l'évaluation par VBA d'une formule fournisse le même résultat que la formule elle-même !
:eek:
 

Si...

XLDnaute Barbatruc
Re : [RESOLU] : VBA compter nombre cellule non vide dans une plage

salut

bien que des réponses aient été données, contrôle (pour avoir moins peur ;))

formule
=NBVAL(A1:A100)
VBA
Code:
MsgBox Application.CountA([A1:A100])
et pour compter le nombre de cellules vides
Code:
MsgBox Application.CountBlank([A1:A100])
Il est intéressant de connaître la méthode illustrée par
Fonctions VBA.jpg
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas