Microsoft 365 [RÉSOLU] Impossibilité Rechercher Remplacer avec Index+Equiv

sprjacky

XLDnaute Nouveau
Bonjour à tous,

Dans une des feuilles de mon classeur, le menu Crtl+H pour Rechercher et Remplacer une lettre par une autre ne fonctionne pas.
Je sélectionne ma colonne, et j'ouvre le menu Rechercher Remplacer, mais lorsque je clique sur Remplacer tout, Excel ouvre une fenêtre et me demande d'ouvrir un nouveau fichier.
Lorsque je choisis d'annuler, je retrouve des #N/A, et ce sont les formules de la colonnes qui ont été modifiées avec le texte de remplacement.

C'est la première fois que je retrouve ce cas de figure, et lorsque je fais la même manipulation sur une autre feuille du même classeur, je n'ai pas ce soucis et tout fonctionne.

Savez-vous à quoi cela est dû et comment résoudre le problème ?

Je ne peux malheureusement partager ce fichier...

Merci d'avance pour votre aide ^^
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
Lorsque tu fais le remplacement, tu changes un nom de fichier ou de feuille qu'excel ne trouve pas.
La valeur que tu remplaces n'est peut-être pas assez précise pour ne remplacer que ce que tu veux
par exemple si tu veux remplacer C par V pour changer une colonne tu vas aussi changer le fichier ou la feuille nommée Critère en Vritère et là Excel te demande où est ce fichier ou cette feuille.
Il vaut parfois mieux de remplacer $C par $V par exemple

Cordialement
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir,
C'est aussi vrai pour les formules. Par ex :
B2 : Si demain il fait beau …
B3 : =SI(B2="";"";1) alors B3=1
On remplace dans colonne B Si par Comme :
B2 : Comme demain il fait beau …
B3 : =Comme(B2="";"";1) alors B3= #NOM?
 

sprjacky

XLDnaute Nouveau
Bonjour,

@Dugenou mettre des $ avant la valeur cherchée ne fonctionne pas...
Ma colonne de valeur provient d'un index equiv peut être que la manip Rechercher/Remplacer est incompatible avec une colonne contenant cette formule?

Je ne sais pas comment contourner le problème !

Cdt
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas