{RESOLU} Ajout d'une année automatiquement dans des cellules d'un calendrier

Paf

XLDnaute Barbatruc
Re : Ajout d'une année automatiquement dans des cellules d'un calendrier

Bonjour

une proposition qui ne répond pas tout à fait à la demande puisqu'elle n'affiche pas que le nombre d'années
mais l' age en années, mois et jours.
l'année de naissance ( ou d'acquisition...) doit être saisie en colonne G.


la formule suivante à copier en A2 puis tirer vers le bas
=SI(G2<>"";DATEDIF(DATEVAL(B2&"/"&A2&"/"&G2);AUJOURDHUI();"y")&" ans "&DATEDIF(DATEVAL(B2&"/"&A2&"/"&G2);AUJOURDHUI();"ym")&" mois "&DATEDIF(DATEVAL(B2&"/"&A2&"/"&G2);AUJOURDHUI();"md")&" jour(s)";"")

Bonne suite
 

Fichiers joints

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Ajout d'une année automatiquement dans des cellules d'un calendrier

Bonsoir, Papy 100, Paf :)

Je n'ai vu aucune notion d'année dans votre fichier. Il va être difficile de savoir quand on passe à l'année suivante.
Si au moins on savait quelle date permet d'indiquer 36 ans, 6 degrés ??? ou 70 ans dans les échéances de votre exemple...
Utilisez donc des dates normales (jj mm aa), plutôt qu'un éclaté jour-mois (colonnes 1 et 2), et une date début plutôt quun âge en colonne F.

Et pour votre prochain message, utilisez ce cadre pour expliquer votre problème, plutôt qu'une zone de texte dans la pièce jointe.
Tous n'ouvrent pas les PJ, ce qui explique peut-être le peu de réponses à votre demande.
 

Papy 100

XLDnaute Occasionnel
Re : Ajout d'une année automatiquement dans des cellules d'un calendrier

Bonjour le forum et d'avance merci à celles et ceux qui me donnent le coup de main

MERCI à vous victor21 et Paf pour votre aide - et la solution de Paf est très proche de ma demande.

Je possède un calendrier perpétuel pour tous les évènements qui se passent dans la société.
Il y a 14 feuilles - L'année est demandée dans le feuille "Janvier" cellule C2. Ma PJ est une partie de la feuille "opérations"

Ma demande :

Je souhaiterai que dans la colonne "F" les nombres inscrits changent automatiquement à leur date anniversaire -
J'ai ajouté une colonne "G" pour le premier évènement; car dans mon calendrier, c'est le résultat de la colonne "F" qui est indiquée.

Grands MERCIS de vous occupez de moi Patrick
 

Discussions similaires


Haut Bas