[RESOLU]_Recherche sur 2 colonnes et extraire dans la 3ème?

Gdal

XLDnaute Nouveau
Bonsoir,

J'ai un tableau
ID...Marque...Reference
1...Marque1...Reference1
2...Marque1...Reference2
3...Marque2...Reference1

Je cherche à extraire la valeur de l'ID correspond aux critères de la colonne Marque et Reference.
J'ai tenté deux formules:
Code:
=INDEX(Tableau1[ID];EQUIV(F2 & G2;Tableau1[[Marque]:[Reference]];0))
=DECALER(Tableau1[ID];EQUIV(F3 & G3;Tableau1[[Marque]:[Reference]];0)-1;0)
Je vous joins un fichier exemple. Voir la pièce jointe Classeur2.xlsx

Merci pour le coup de main

Gdal
 

Fichiers joints

Dernière édition:

Fred0o

XLDnaute Accro
Re : Recherche sur 2 colonnes et extraire dans la 3ème?

Bonsoir Gdal,

Cette formule à mettre en H2 et à tirer vers le bas :
Code:
=SOMMEPROD((Tableau1[Marque]=F2)*(Tableau1[Reference]=G2)*Tableau1[ID])
A+
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re : Recherche sur 2 colonnes et extraire dans la 3ème?

Bonsoir.

Pour aller au plus simple, concaténez les colonnes B et C, et effectuez la recherche sur cette nouvelle colonne.

Edit : Oubliez ma solution "bourrin" La solution de Fred0o, que je salue :) est bien plus élégante, puisque l'IDest numérique :)
 
Dernière édition:

mapomme

XLDnaute Barbatruc
Supporter XLD
Re : Recherche sur 2 colonnes et extraire dans la 3ème?

Bonsoir Gdal,

Une piste en utilisant une formule matricielle en H2 à tirer vers le bas:
Code:
=INDEX(Tableau1[ID];EQUIV(F2&"]"& G2;Tableau1[Marque]&"]"& Tableau1[Reference];0))
Formule matricielle: Elle doit être validée par la combinaison des touches Ctrl+Maj+Entrée au lieu de la seule touche Entrée comme une formule classique.
Si la validation matricielle est correcte, alors Excel entoure la formule d'accolades {=.......}.
Chaque fois que cette formule sera modifiée, la validation devra se faire par Ctrl+Maj+Entrée. Les accolades apparaissent à la validation et ne doivent pas être saisies au clavier.
 

Fichiers joints

Dernière édition:

Gdal

XLDnaute Nouveau
Re : Recherche sur 2 colonnes et extraire dans la 3ème?

Bonjour,

Merci tout le monde.
Dans un premier temps, je me suis servi de la solution Fred0o, mais en faite elle ne fonctionne qu'avec les colonnes de type numérique.

Je me suis rabattu sur la solution de bourin de Victor21
Code:
=SIERREUR(INDEX(Tableau1[CodeLidic];EQUIV(H3;Tableau1_MarqueReference;0));"")
Ou
Tableau1[CodeLidic] est la colonne CodeLidic
Tableau1_MarqueReference est la concaténation des colonnes Marque et Référence =Tableau1[Marque]&" "&Tableau1[Reference]

Le fichier Voir la pièce jointe Classeur2_v2.xlsx

Merci tout le monde,

Gdal
 

Haut Bas