Office 365 Remplissage tableau VLookUP, 3 conditions

VazyFrancko

XLDnaute Nouveau
Bonjour,
A partir du tableau dans la feuille "Input", je cherche à générer le tableau qui se trouve dans la feuille"Output"
Il s'agit d'un vlookup à 3 critères.
Pourriez-vous m'aider svp?
Merci
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

En "C2", à essayer:
VB:
=SIERREUR(DECALER(Input!$D$1;EQUIV($A2&$B2&C$1;Input!$C$2:$C$10&Input!$A$2:$A$10&Input!$B$2:$B$10;0););0)
Formule matricielle à valider par Ctrl+Maj+Entrée

JHA
 

Fichiers joints

VazyFrancko

XLDnaute Nouveau
Bonjour,
merci pour votre message.
En fait une macro serait la bienvenue car en réalité, le nombre de ligne est très élevé.
 

merinos

XLDnaute Occasionnel
Salut @VazyFrancko ,

C'est trop simple avec un query...

Tu fais juste un "refresh" du tableau solution & il est complet...

En 3 click c'est créé: filtré, pivoté et rangé...
1033246
 

Fichiers joints

VazyFrancko

XLDnaute Nouveau
Salut merinos,
Ta solution m'a l'air parfaite.
N'étant pas familier avec Query, peux-tu stp me faire parvenir le "chemin" d’exécution pour parvenir à ce résultat?
Merci beaucoup.
 

merinos

XLDnaute Occasionnel
Quelle version d'Excel emploies tu?

Query est une option a installer dans excel 2013, mais inclus depuis Excel 2016 et plus


Tu trouves Query dans l'onglet "Data"...
Tu te place dans ton tableau
tu actives un query en selectionnant ce menu:
1033255

puis tu te laisse porter par la super interface.
Tu peux lire les etapes de tes query en les affichant et les EDITANTS...
 

Discussions similaires


Haut Bas