recherchev #n/a

napo124

XLDnaute Junior
Bonjour!:)

J'ai un fichier excel avec deux feuilles:
Première feuille ("articles"):
ligne A : noms des articles
lignes suivantes: Outils associés à l'articles

Deuxième feuille ("outils"):
ligne A: nom d'une sélection d'articles
ligne B: Position des articles sélectionéss dans la ligne des noms des articles de la feuille 1
Colonne A: liste de tout les outils possibles présents dans la feuille 1

Mon objectif est alors d'associer un chiffre (0 ou 1) sur chaque cellule de la feuille 2 afin de savoir si l'outil concerné dans la ligne est présent dans la liste des outils associés à l'article concerné dans la feuille "articles". Donc 0 pour non et 1 pour oui.

Mes formules copier coller sont alors:
=SI( esterreur( recherchev($A3; articles!A2:CV ; B$2 ; faux) ) ; 0 ; 1)

Le problème vient de ma fonction recherche qui me donne toujours #N/A et donc qui me fout en l'air le calcul.

Je ne comprends pas, ça devrait marcher non? Pourtant les formats sont bien en nombres et correspondent.
Voyez vous le problème?
 

napo124

XLDnaute Junior
Re : recherchev #n/a

Petit exemple pour mieux comprendre:

Feuille1:

REFARTICLE1 -- REFARTICLE 2 ------REF...
4654 ---------- 4661
1654 ---------- 4665
4687 ---------- 1654
4985 ---------- 4874
1235 ---------- 1546



Feuille 2:

--------REFARTICLE3----REFARTICLE1
--------3---------------1

4423---0----------------0
1235---1----------------0
4665---0----------------1
7489---0----------------0
....
 

napo124

XLDnaute Junior
Re : recherchev #n/a

Voilà un extrait du fichier.
Si au final il n'y a que 5% de 1 ce sera normal (pas beaucoup d'outils en feuille2)
 

Pièces jointes

  • Classeur1.zip
    5.1 KB · Affichages: 40
  • Classeur1.zip
    5.1 KB · Affichages: 36
  • Classeur1.zip
    5.1 KB · Affichages: 34

Monique

Nous a quitté
Repose en paix
Re : recherchev #n/a

Bonjour,

En nommant "Zone" la plage A2:A200 (ou plus) de la feuille « Articles »
En B3 de la feuille "Outils"
=ESTNUM(EQUIV($A3;DECALER(Zone;;B$2-1);0))*1

La position des articles en ligne 2 de "Outils"
En B2 et copier-coller vers la droite :
=EQUIV(B1;articles!$A1:$L1;0)
 
Haut Bas