Résolu Recherche sur plusieurs lignes

Lealea

XLDnaute Nouveau
Bonjour,

J'aimerais réussir à obtenir le résultat suivant :
1035803
J'ai une colonne 1 où il y a une première partie qui m'intéresse (ici A) et une deuxième partie qui sert à différencier chaque ligne.
Je voudrais, pour chaque ligne commençant par cette première partie (A) faire la somme, pour chaque ligne, de la colonne 2 de cette ligne fois la colonne 3 de cette ligne.
Mon exemple est surement plus parlant que mon explication.
Il me faudra alors faire la même chose pour les B et ainsi de suite.
Je sais récupérer les deux premiers résultats correspondant à A et je sais faire la somme de toutes les valeurs de la colonne 2 correspondant à A mais là je bloque.
Évidemment je ne peux pas le faire à la main car j'ai plusieurs dizaines de lignes.

Vous auriez une idée ?

Merci beaucoup d'avance.
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Lealea,

Pas facile de tester nos proposition sur une image :(

mais un essai quand même

VB:
=SOMMEPROD((Gauche(A2:A6;1)="A")*(B2:B6*C2:C6))
si cela ne marche pas met le fichier excel dont est tiré l'image

Cordialement
 
Dernière édition:

Lealea

XLDnaute Nouveau
Bonjour, merci de ta réponse.
Je mets le fichier ici, je n'y avait pas pensé.
Le probléme avec ta formule est que je ne peux pas utiliser la fonction gauche car le nombre de caractères n'est jamais le même. Là c'est juste un exemple simplifié.
 

Fichiers joints

Lealea

XLDnaute Nouveau
Merci pierrejean ça marche super mais le problème c'est que je ne sais pas du tout comment utiliser les macros...
Il y aurait possibilité de faire sans ?
 

Jocelyn

XLDnaute Barbatruc
Re,
Bonjour l'ami PierreJean :),

@Lealea, peux tu joindre différend modele de donnée en colonne A, ton premier message parlait commençant par "A" un peu plus d'explication et de cas différends

Cordialement
 

Lealea

XLDnaute Nouveau
En fait, je ne peux pas me fier au nombre de caractères car ils ne sont jamais les mêmes.
Il me faudrait, pour les lignes, commençant pas certain caractères avoir la somme de la colonne2*colonne3 pour toutes ces lignes
 

Fichiers joints

pierrejean

XLDnaute Barbatruc
Re

Il n'est pas utile de connaitre les macros avec le fichier que j'ai posté
il suffit de mettre tes données dans les colonnes A B et C
 

Lealea

XLDnaute Nouveau
pierrejean, je dois intégrer ces calculs dans un fichier excel où ces données ne seront pas sur les mêmes pages. Et le bouton pour calculer c'est pas ce qu'il me faut car il faut que ce soit automatique et instantané.
En plus, je ne peux pas utiliser des fonctions que je ne comprend pas puisque je dois faire quelque chose de maintenable facilement car devant évoluer régulièrement..
Je pourrais me former au macro si je devais absolument mais j'aimerais autant éviter de les utiliser pour une formule. J'ai pu faire tout le reste sans.
En tout cas merci beaucoup :)
 

Discussions similaires


Haut Bas