Problème de Formule avec recherchev et Equiv

apb

XLDnaute Occasionnel
Bonjour à Tous
D'abord Merci pour votre aide.

J'ai un problème de résolution d'erreur dans une formule qui est composé de recherchev() et de equiv()

Pouvez vous me donner un coup de main

D'avance je vous en remercie

ci-joint un fichier qui explique mon problème

Cordialement

APB
 

Pièces jointes

  • Classeur2.xls
    48.5 KB · Affichages: 57
  • Classeur2.xls
    48.5 KB · Affichages: 70
  • Classeur2.xls
    48.5 KB · Affichages: 64

Tibo

XLDnaute Barbatruc
Re : Problème de Formule avec recherchev et Equiv

bonjour apb,

Un problème de base sur ton fichier.

Dans ton 2ème tableau, tu fais une recherche sur la base de GIE-AC alors que dans ton 1er tableau, c'est GIEAC.

Il faut que tes critères de recherches soient strictement identiques.

Sinon, une solution à base de INDEX et EQUIV :

En C4 de ton 2ème tableau :

=INDEX(TreEquipeDice;EQUIV($B4;bd!$A$772:$A$779;0)+1;EQUIV(C$3;bd!$D$771:$BC$771;0)+3)

à recopier vers le bas et vers la droite

Teste et dis nous

@+
 

BrunoM45

XLDnaute Barbatruc
Re : Problème de Formule avec recherchev et Equiv

Salut Apb,

Quand tu as un problème comme celui-là, un bon principe de base, c'est de décomposer sa formule dans des cellules différentes.

Dans une 1ère cellule "C2" par exemple, tu mets : EQUIV(C$3;bd!$A$771:$BC$771;0)
-> Tu vois que ça marche comme ça

Dans une 2ème "D2", tu mets : =RECHERCHEV($B4;TreEquipeDice;C2)
-> Tu vois que ça marche

Ce qui te permet de déterminer ton erreur et de modifier ta formule complète par :
[CODE]=RECHERCHEV($B4;TreEquipeDice;EQUIV(C$3;bd!$A$771:$BC$771;0))[/code]

A mettre dans ta cellule C4

Voilà ;)
 

chris

XLDnaute Barbatruc
Re : Problème de Formule avec recherchev et Equiv

Bonjour
Comme Tibo j'ai remarqué que la base et recherche ne sont pas cohérentes.
J'avais pour ma part modifié la colonne C de la base et remplacé les 2 tirets par un seul.
J'ai nommé la 1ère ligne de la base TreEquipeDiceLig et la colonne C de la base TreEquipeDiceCol
Ce qui donne comme formule en C4
=INDEX(TreEquipeDice;EQUIV($B4;TreEquipeDiceCol;0);EQUIV(C$3;TreEquipeDiceLig;0))
Formule qu'il faudrait revoir pour les cas où la recherche n'aboutit pas.

Cependant la finalité m'échappe : je ne vois pas l'utilité de mettre la base à cet emplacement pour finalement refaire le même tableau.
Les hyperliens sont également faux.

A suivre donc....
 

apb

XLDnaute Occasionnel
Re : Problème de Formule avec recherchev et Equiv

Bonjour Tibo, Bruno45 et Chris
Merci pour votre aide

Je viens de tester et essayer de comprendre mon erreur à partir du découpage que Bruno45 a proposé.

Pour equiv() ok c'est bon
Mais pour recherchev() j'ai un décalage dans les colonnes

ci-joint un fichiers exemple

Merci pour votre aide à Tous

Cordialement

APB
 

Pièces jointes

  • Classeur4.xls
    39 KB · Affichages: 63
  • Classeur4.xls
    39 KB · Affichages: 67
  • Classeur4.xls
    39 KB · Affichages: 67

Monique

Nous a quitté
Repose en paix
Re : Problème de Formule avec recherchev et Equiv

Re,

Il y a le même décalage dans tout le tableau à partir de la ligne 7 et pas seulement en colonne J
Ce n'est pas C4 qu'il faut chercher, c'est A4
Et il manque le dernier argument de la fonction Recherche() : 0 ou FAUX pour avoir la valeur exacte
Avec l'argument 1 ou VRAI ou rien, tu obtiens la 1ère valeur trouvée la plus proche et encore… à condition que les données soient triées.

En D4 :
=RECHERCHEV($A4;$A$24:$BP$32;D$2;0)

Pas beaucoup plus long et tu peux effacer la ligne 2 :
=RECHERCHEV($A4;$A$24:$BP$32;EQUIV(D$3;$A$24:$BP$24;0);0)
 
Haut Bas