Problème d'arrondis avec formules matricielles

Scoty

XLDnaute Junior
Bonjour à tous,

je souhaite faire un calcul matricielle avec du recherchev() et si(). Cependant, le résultat que je devrais trouver n'y est pas, j'ai un arrondi.

Pour résumé, j'ai un tableau à 3 entrées: "code", "nombre d’heures" et "nombre de jours". on remplit le "nombre de jours" en dur pour trouver le nombre d'heures via une recherchev avec un autre tableau de données et l'entrée "code"

Avec la formule matricielle, je devrais retrouver le nombre de jours que j'ai rentré en dur...et j'ai un arrondi!

Pouvez vous m'aider?

En vous remerciant dans l'attente de vous lire.

@+
Scoty
 

Fichiers joints

CISCO

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonsoir

Il me semble que le RECHERCHEV ne fonctionne pas en matriciel ici. Pour vérifier cela, cliques sur Formules, puis sur Evaluation de formule. Ta formule divise tout par 13, et non pas certains nombres de la colonne B par 13, d'autres par 11 et d'autres par 10.

@ plus
 

excfl

XLDnaute Accro
Re : Problème d'arrondis avec formules matricielles

Bonsoir Scoty, CISCO

Une solution ?

D9 : =RECHERCHEV(A9;$C$2:$D$4;2;FAUX)

A tirer vers le bas.

E17 : =SOMMEPROD(((B9:B16))/D9:D16)


excfl
 

Scoty

XLDnaute Junior
Re : Problème d'arrondis avec formules matricielles

Bonsoir excfl,
Merci de la solution. J'y avais pensé mais le soucis c'est que le fichier que j'ai envoyé n'est qu'une partie d'un enorme tableau, et je voulais trouver une solution directement sans passé par des calculs annexes.

Bonsoir cisco,
effectivement, j'ai remarqué l'anomalie dans l'évaluation. Pour tenter de trouver une explication, j'ai réalisé la formule matricielle ligne par ligne, et j'ai constaté que cela ne fonctionnait que pour la division par 13...
 

job75

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonjour Scoty, CISCO, excfl,

Ce que vous voulez faire n'est guère classique.

Alors voyez cette formule matricielle en E17 :

Code:
=SOMME(SI(A9:A16=TRANSPOSE(C2:C4);B9:B16/TRANSPOSE(D2:D4)))
Le résultat est bien 8.

A+
 

CISCO

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonjour

Bien vu, job75, l'utilisation de TRANSPOSE ici. Je n'y aurai pas pensé. Comme quoi, c'est parfois utile de "détourner" certaines fonctions...

@ plus
 

R@chid

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonjour @ tous,
Salut les amis :)
@ Scoty :
Pour ta formule matricielle avec RECHERCHEV(), elle est opérante sur "OpenOffice Calc"...

@ + +
 

job75

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Re CISCO, hello R@chid,

TRANSPOSE permet de créer ici des matrices à 2 dimensions.

En passant, bien noter qu'il ne doit pas y avoir de doublons dans la plage des codes C2:C4.

A+
 

Scoty

XLDnaute Junior
Re : Problème d'arrondis avec formules matricielles

Bonsoir à tous,

Merci pour votre participation. mon calcul matricielle fonctionne. Pour info j'ai pu réussir à le faire aussi avec un somme.si ;)

Vous êtes au top!

@+
sCOTY
 

R@chid

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonsoir @ tous,
Merci de nous dire comment tu as pu le faire avec SOMME.SI() et sans colonnes intermédiaires.

@ + +
 

Scoty

XLDnaute Junior
Re : Problème d'arrondis avec formules matricielles

En colonne G, j'ai fait un test avec un somme prod, mais ça ne marche pas.

En H avec avec des conditions si()... et ça marche. Ne pas prendre en compte les calculs intermédiaires, j'avais pris des exemples avec une condition que j'ai rajouté. Bien voir la formule en H17:

Code:
=SOMME((C9:C16)/SI(B9:B16=$D$2;$E$2;SI(B9:B16=$D$3;$E$3;SI(B9:B16=$D$4;$E$4))))
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonjour,
On ne peut pas appeler ça une formule, c'est incomparable avec la formule de l'ami Job75,
Tu vas dire pourquoi ??
Ok je vais te répondre :
Imagines que l'on a des dizaines de codes ???
Comme bien de "SI" il te faudra pour t'en sortir ???

Tu voies ce que je veux dire ?

@ + +
 

Scoty

XLDnaute Junior
Re : Problème d'arrondis avec formules matricielles

Rachid ma solution n'est certainement pas la plus efficace, effectivement, en comparaison à celle de job75. Néanmoins les forums sont là pour partager, proposer des astuces pour trouver des solutions, balancer ses états d’âmes ne font rien avancer. en attendant ma fonction fonctionne, ça demande juste une petite gymnastique cérébrale même ac beaucoup de conditions.
 

job75

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonsoir à tous,

ça demande juste une petite gymnastique cérébrale même ac beaucoup de conditions.
On sait que sur XLD il y a beaucoup d'adeptes du "plus c'est long plus c'est bon" :)

Bonne fin de soirée.
 

Staple1600

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Bonsoir à tous

[ETAT D'AME]
Job75 ;)
Et on sait aussi que R@chid et toi, vous maîtrisez encore très mal les formules avec Excel.
Et quant on voit vos codes VBA, on voit le chemin qu'il vous reste à parcourir pour maîtriser Excel.

Moi je dis que Scoty a tout a fait raison de demander l'aide sur le forum pour au final choisir sa formule à lui.
[/ETAT D'AME]
 

job75

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Hello Jean-Marie :D

Bon soyons indulgents, ça fait juste 15 jours que Scoty s'est inscrit.

A+
 

Staple1600

XLDnaute Barbatruc
Re : Problème d'arrondis avec formules matricielles

Re


Job75
Je suis indulgent.
Ironiquement indulgent mais indulgent quand même ;)

Et plus que Monsieur Spock...

Téléportation, Scotty! (mais en Option Explicit) ;)
 

job75

XLDnaute Barbatruc

Scoty

XLDnaute Junior
Re : Problème d'arrondis avec formules matricielles

Bonjour Job,

Formule qui fonctionne à la perfection.

Merci.

@+ Bonne journée
Scoty
 

Discussions similaires


Haut Bas