Résolu Microsoft 365 petit probleme de date

al1plongee

XLDnaute Nouveau
bonjour,
voila le problème:
dans des cellules j'ai de dates ou pas (noté "Non valide")
colonne suivante les date de fin et colonne en dernier L’état
ce qui donne par exemple:
E2 F2 G2
06/10/2020 -> 5/10/2021 -> ok (ou attention si dépassement)
mais j'ai aussi:
Non valide 0 attention ==============> formule =SI(F2-60<AUJOURDHUI();"ATTENTION";"OK")
par contre si je répète la formule dans toute la colonne, je ne peux pas avoir le calcul soit avec une date non valide soit avec une date reelle. j'ai essayé avec ou mais ca ne fonctionne pas.
bon j’espère que vous m'avais compris, sinon je suis a votre disposition
cordialement
AL1
 
Ce fil a été résolu! Aller à la solution…

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour AL1, C'est pas clair.
Vous n'auriez pas un tout petit fichier test qui montre le problème.
D'après ce que j'ai compris qu'il fallait exclure les données non valides, dans ce cas essayez :
VB:
=SI(F2=0;"Invalide";SI(F2-60<AUJOURDHUI();"ATTENTION";"OK"))
 

al1plongee

XLDnaute Nouveau
bonjour,
voila le problème:
dans des cellules j'ai de dates ou pas (noté "Non valide")
colonne suivante les date de fin et colonne en dernier L’état
ce qui donne par exemple:
E2 F2 G2
06/10/2020 -> 5/10/2021 -> ok (ou attention si dépassement)
mais j'ai aussi:
Non valide 0 attention ==============> formule =SI(F2-60<AUJOURDHUI();"ATTENTION";"OK")
par contre si je répète la formule dans toute la colonne, je ne peux pas avoir le calcul soit avec une date non valide soit avec une date reelle. j'ai essayé avec ou mais ca ne fonctionne pas.
bon j’espère que vous m'avais compris, sinon je suis a votre disposition
cordialement
AL1
j'ai oublié, dans la cellule F2 j'ai: =SI(E2="Non valide";"0"),
je voudrais donc lier les deux formules dans une seule
merci d'avance
AL1
Bonjour AL1, C'est pas clair.
Vous n'auriez pas un tout petit fichier test qui montre le problème.
D'après ce que j'ai compris qu'il fallait exclure les données non valides, dans ce cas essayez :
VB:
=SI(F2=0;"Invalide";SI(F2-60<AUJOURDHUI();"ATTENTION";"OK"))
merci pour cette première approche. je me doutais que mon message n’était pas très clair
je joint un extrait de mon fichier
cordialement
AL1
 

Fichiers joints

cp4

XLDnaute Impliqué
Bonjour Al1,

un essai
 
Ce message a été identifié comme étant une solution!

Fichiers joints

al1plongee

XLDnaute Nouveau
bonjour,
merci pour la solution ....
des fois je vais chercher bien loin ce qui est tout pres .... bon mon fichier de gestion a des formules bien alambiquées.... il faudra un jour que je revois ca de fond en comble.
encore merci
AL1
 

al1plongee

XLDnaute Nouveau
bonjour,
en fait ca ne fonctionne pas si bien.
pour la cellule de date de fin ok, mais pour la cellule etat ne fonctionne pas,. lors de la lecture de date de fin, si la date de fin est anterieur a la date du jour cela me met toujours OK, alors qu'il devrait me mettre ATTENTION
bon je gratte le probleme
merci quand meme
AL1
 

cp4

XLDnaute Impliqué
bonjour,
en fait ca ne fonctionne pas si bien.
pour la cellule de date de fin ok, mais pour la cellule etat ne fonctionne pas,. lors de la lecture de date de fin, si la date de fin est anterieur a la date du jour cela me met toujours OK, alors qu'il devrait me mettre ATTENTION
bon je gratte le probleme
merci quand meme
AL1
C'est juste parce que tu n'as aucune date antérieure à aujourd'hui (4/6/2020).
Al1.gif
 

al1plongee

XLDnaute Nouveau
bonjour,
je pense que c'est cela (j'avoue ne pas avoir bosser le sujet ce we)
en tous cas merci pour le depannage
cordialement
AL1
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas