Microsoft 365 Erreur Calcul Dates

richard31

XLDnaute Occasionnel
Bonjour

Je reviens vers vous car je vais devenir chèvre !
Voila j'ai un tableau avec des dossiers traités et quantifié avec des dates. J'ai une colonne qui indique a qu'elle date à été ait la demande. Jusque là ok. J'ai fait un rapport qui va rechercher pour quel mois combien de demandes ont été effectuée : Exemple pour le mois de janvier aller voir dans la colonne combien de demande sont identifées. J'ai fais une formule qui fonctionne :
=NB.SI.ENS(TCD!$AM$4:$AM$10000;">="&1&C6;TCD!$AM$4:$AM$10000;"<"&MOIS.DECALER(1&C6;1))
Je vais dans TCD ou j'ai des tableau croisée dynamiques (plus facile à gérer pour les données associées que je veux prendre en compte), et sur la colonne du TCD situé entre AM4 et AM10000 ou il y a les dates. dans la formule En C6 c 'est le mois indiqué pour lequel je veux des résultats

C'est là que je comprends pas !! si la date est en 2021 ça fonctionne mais pas si je passe en 2022 ? WTF ????

Attention obligé de travailler qu'avec des formules et non VB car utilisation forcée de la version excel Web (ouai deg).

De plus je dois faire un tableau par année ! un pour 2021 un pour 2022 et donc qui ne prend en compte que l'année 2022 dans les dates analysée. et bien je ne sais pas comment adapter la formule ci-dessous pour lui dire attention dans ce tableau ce ne sera que pour 2021 et celui-là 2022.

Voilu j'y arrive pas :(

Ci-joint le fichier anonymisé
 

Pièces jointes

  • DOC DE TRAVAIL.xlsx
    22.1 KB · Affichages: 8

JHA

XLDnaute Barbatruc
Bonjour à tous,
@richard31

Peux-tu essayer
VB:
=NB.SI.ENS(TCD!$AM$4:$AM$10000;">="&DATE(2021;MOIS(1&C6);1);TCD!$AM$4:$AM$10000;"<"&FIN.MOIS(DATE(2021;MOIS(1&C6);1);0))
copier vers la droite
Edit modif formule et fichier

JHA
 

Pièces jointes

  • DOC DE TRAVAIL.xlsx
    22.4 KB · Affichages: 2
Dernière édition:

richard31

XLDnaute Occasionnel
Bonjour à tous,
@richard31

Peux-tu essayer
VB:
=NB.SI.ENS(TCD!$AM$4:$AM$10000;">="&DATE(2021;MOIS(1&C6);1);TCD!$AM$4:$AM$10000;"<"&FIN.MOIS(DATE(2021;MOIS(1&C6);1);0))
copier vers la droite
Edit modif formule et fichier

JHA
merciiiii milles fois cela fonctionne ! L'insertion de la partie avec l'année analysée je n'aurai pas trouvé pourtant pas si complexe.

Encore merci !
 

richard31

XLDnaute Occasionnel
Bonjour à tous,
@richard31

Peux-tu essayer
VB:
=NB.SI.ENS(TCD!$AM$4:$AM$10000;">="&DATE(2021;MOIS(1&C6);1);TCD!$AM$4:$AM$10000;"<"&FIN.MOIS(DATE(2021;MOIS(1&C6);1);0))
copier vers la droite
Edit modif formule et fichier

JHA
Bon j'abuse de ton expertise ! mais comme je ne suis pas doué :(
J'ai cette formule aussi à deux conditions :
=NB.SI.ENS('Données Générales'!$T$7:$T$10000;B34;'Données Générales'!$C$7:$C$10000;"OUI")
Sachant que les dates à prendre en compte sont en colonne H page "Données Générales" Comment faire comme avec la première formule pour lui dire de ne faire le calcul que pour 2021 par exemple ?

:oops:
 

richard31

XLDnaute Occasionnel
Bon j'abuse de ton expertise ! mais comme je ne suis pas doué :(
J'ai cette formule aussi à deux conditions :
=NB.SI.ENS('Données Générales'!$T$7:$T$10000;B34;'Données Générales'!$C$7:$C$10000;"OUI")
Sachant que les dates à prendre en compte sont en colonne H page "Données Générales" Comment faire comme avec la première formule pour lui dire de ne faire le calcul que pour 2021 par exemple ?

:oops:
j'ai fais ça :
=NB.SI.ENS(Entité_émétrice;B33;Demande_principale_pour_la_Cellule;"OUI";Date_Sollicitation;">="&DATE(2021;1;1))

ça fonctionne :)
 
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je ne peux pas t'aider, le fichier que tu as posté n'est pas représentatif (pas de données dans $T$7:$T$10000 et B34.
pas de: Entité_émétrice, "B33", Demande_principale_pour_la_Cellule, Date_Sollicitation
=NB.SI.ENS(TCD!$CJ$4:$CJ$10000;">="&DATE(2021;MOIS(1&C23);1);TCD!$CJ$4:$CJ$10000;"<"&FIN.MOIS(DATE(2021;MOIS(1&C23);1);0))

Désolé, j'ai perdu ma boule de cristal, si tu joins un fichier correct, on essaiera de t'aider.

JHA
 

richard31

XLDnaute Occasionnel
Bonjour à tous,

Je ne peux pas t'aider, le fichier que tu as posté n'est pas représentatif (pas de données dans $T$7:$T$10000 et B34.
pas de: Entité_émétrice, "B33", Demande_principale_pour_la_Cellule, Date_Sollicitation
=NB.SI.ENS(TCD!$CJ$4:$CJ$10000;">="&DATE(2021;MOIS(1&C23);1);TCD!$CJ$4:$CJ$10000;"<"&FIN.MOIS(DATE(2021;MOIS(1&C23);1);0))

Désolé, j'ai perdu ma boule de cristal, si tu joins un fichier correct, on essaiera de t'aider.

JHA
RE
pas de souci je ne vous embête plus ni vous ni votre boule de cristal ^^
Merci encore pour votre aide j'ai réussi à tout faire fonctionner. L'erreur qui restait était juste au niveau de cette partie de la formule :
"<"&FIN.MOIS(DATE(2021;MOIS(1&C6);1);0))
il fallait rajout le = comme suit :
"<="&FIN.MOIS(DATE(2021;MOIS(1&C6);1);0))
Et la plus aucun souci !

Bonne journée