Autres organisation d'un tournoi de badminton

GREG MDS

XLDnaute Junior
Bonjour, je suis moniteur de sport pénitentiaire

je souhaiterai pour l'organisation de nos tournois de badminton développer mon tableau excel ci joint

cependant je n'arrive pas a créer les cellules pour qu'il calcul le vainqueur pts nb de victoire et défaites et mettre le classement dans l'ordre
si possible également vérifier ou mettre en place une formule pour la différence.

je souhaiterai également une touche rapide pour effacer toutes les données

est enfin faire en sorte que ma phase final apparait directement selon le classement des poules.

merci de votre collaboration
Grégory
 

Pièces jointes

  • poule tournoi bad 2021.xls essais.xls
    20 KB · Affichages: 8

GREG MDS

XLDnaute Junior
BONJOUR
Effectivement JHA
ça se joue en deux sets gagnant de 21 points avec 2points d'écarts.

victoire =3pts
défaite = 0 pt

est-il possible également de créer un tirage au sort aléatoire à partir de la feuille d'inscription dispatchée dans les feuilles de poule ; avec un jolie bouton tirage au sort?

merci beaucoup
 

GREG MDS

XLDnaute Junior
ca évolue encore a force de recherche ...
j'ai réussi la macro pour réinitialiser le tournoi

il me reste donc plus qu'a comprendre comment on fait un tirage au sort aléatoire avec les personnes inscrites

comment calculer une victoire au badminton (2 sets gagnés) et donc une défaite (0 ou 1 set gagné)
comment attribué le nombre de points '3pour une victoire 0 en cas de défaite)

et enfin classe dans mon tableau finale les équipes selon leur rang en poule
et faire défiler les vainqueurs de chaque rencontre en finale ...

merci d'avance pour vos aide
Bonjour à tous,

Tu es un peu léger pour les explications, un début de piste à compléter.

JHA
Merci beaucoup
j'ai fais des annotations dans les pages inscriptions et pouleA pour que tu me comprennes mieux
merci d'avance
 

Pièces jointes

  • poule tournoi bad 2021.xls essais.xls
    86 KB · Affichages: 1
  • poule tournoi bad 2021.xls essais.xls
    21.5 KB · Affichages: 3

JHA

XLDnaute Barbatruc
Bonjour à tous,

Ci joint une autre approche, les colonnes de calculs sont masquées.

Pour les macros, pas pour moi, je suis nul en code VBA

Il te reste l'onglet "Tab16" à compléter.

JHA
 

Pièces jointes

  • poule tournoi bad 2021.xls essais (3).xls
    75 KB · Affichages: 2

GREG MDS

XLDnaute Junior
bonjour à tous
merci JHA et JOB 75

cependant des anomalies sont dans les pages poule (je t'ai fais des annotations)
En faite le problème est que le set gagné dans ton cas génère des points alors qu'il faut gagner le match pour capitaliser les 3 points.

le set se gagne lorsque le joueur atteint 21 points avec deux points d'écart. (21/18 ; 21/17; 21/16 ;21/15 ect ....) ou ...
les possibilités sont donc multiples ( ex 20/22 ; 21/23; 22/24 ect ..... le 39 ème point est décisif même si il y a un point d'avance.....)
 

Pièces jointes

  • poule tournoi bad 2021 essais (3).xlsx
    43 KB · Affichages: 3

GREG MDS

XLDnaute Junior
29
bonjour à tous
merci JHA et JOB 75

cependant des anomalies sont dans les pages poule (je t'ai fais des annotations)
En faite le problème est que le set gagné dans ton cas génère des points alors qu'il faut gagner le match pour capitaliser les 3 points.

le set se gagne lorsque le joueur atteint 21 points avec deux points d'écart. (21/18 ; 21/17; 21/16 ;21/15 ect ....) ou ...
les possibilités sont donc multiples ( ex 20/22 ; 21/23; 22/24 ect ..... le 30ème point est décisif même si il y a un point d'avance.....)
le match lui se gagne des que le joueur atteint 2 set gagné (2/0 ou 2/1)
 
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

La fonction sommeprod() recherche la différence des points >=2
VB:
=SOMMEPROD(--((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)-DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+2;1;;3))>=2))
Par contre je ne regarde pas si tu es arrivé à 21 mais tu peux modifier les formules comme cela:
Code:
=SOMMEPROD((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)>20)*(--((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)-DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+2;1;;3))>=2)))
Concernant les points, j'ai modifié les formules si les victoires par match sont supérieures à 1 alors 3 points.

Désolé, je n'ai pas regardé ton fichier mais je me suis épaulé sur tes explications.


JHA
 

Pièces jointes

  • poule tournoi bad 2021 essais (4).xlsm
    37.3 KB · Affichages: 5

GREG MDS

XLDnaute Junior
Bonjour à tous,

La fonction sommeprod() recherche la différence des points >=2
VB:
=SOMMEPROD(--((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)-DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+2;1;;3))>=2))
Par contre je ne regarde pas si tu es arrivé à 21 mais tu peux modifier les formules comme cela:
Code:
=SOMMEPROD((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)>20)*(--((DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+1;1;;3)-DECALER($A$1;EQUIV($U3;$A$3:$A$6;0)+2;1;;3))>=2)))
Concernant les points, j'ai modifié les formules si les victoires par match sont supérieures à 1 alors 3 points.

Désolé, je n'ai pas regardé ton fichier mais je me suis épaulé sur tes explications.


JHA
Bonjour à tous
merci JHA,
Dernier petit conseil stp; quelle formule dois-je appliquer pour faire figurer le vainqueur en phase finale stp? (vainqueur même procédé qu'en phase de poule 2 sets 0 ou 2 sets à 1); et comment fais tu la mise en page en poule A dans les autres pages (ne plus voire les lignes inutiles ? stp merci pour tous ce que tu m'as apporter.
 

Pièces jointes

  • poule tournoi bad 2021.xlsm
    42.8 KB · Affichages: 5

Statistiques des forums

Discussions
288 581
Messages
1 893 168
Membres
169 777
dernier inscrit
Bazilecr
Haut Bas