XL 2010 #NOMBRE! sur formule

joss85

XLDnaute Nouveau
Bonjour a tous


Je solicite votre aide pour un probléme de formule.

Comment avoir une cellule vide à la palce de #NOMBRE!.

j 'ai une formule qui me "filtre" suivant un critére en D6.

et si tous n'est pas rempli j'ai #NOMBRE!.

Je joint un exemple pour etre plus explicit.

C'est peut ètre pas la bonne méthode !
et par macro j'en suis incapable.

ça fonctionne mais c'est pas "propre".

Merci
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour joss85,

modifies la formule de cette fçon

Code:
=SIERREUR(INDEX($C$11:$C$17;PETITE.VALEUR(SI($D$11:$F$17=D$6;LIGNE(INDIRECT("1:"&LIGNES($D$11:$F$17))));LIGNES($1:1)));"")
en cellule D21 a étirer vers le bas

comme toi je suis incapable de le faire par VBA:(

Cordialement
 

joss85

XLDnaute Nouveau
Bonjour,

La formule fonctionne ,mais j'aimerais modifier la présentation .
Je voudrais garder l'ordre.
J'ai essayer avec INDEX EQUIV mais ça ne fonctionne pas.

Cordialement
 

Fichiers joints

eriiiic

XLDnaute Barbatruc
Bonjour,

à tête reposée ça devient facile ;-)
Code:
=SI(NB.SI($D11:$F11;$D$6);C11;0)
eric
 

Discussions similaires


Haut Bas