Liste avec mini et maxi

Lisa

XLDnaute Nouveau
Bonjour,

Bonne année à tous,

Grâce aux conseils de ce forum, j'ai réussi à obtenir la liste ci-jointe
pour chaque nom, je souhaite obtenir l'année minimum et maximum
j'ai mis un exemple de la liste que je souhaite obtenir.
Cette liste servira à mettre à jour une base de patronymes sur internet
D'avance merci
Lisa
 

Pièces jointes

  • Classeur1.xls
    31 KB · Affichages: 69
  • Classeur1.xls
    31 KB · Affichages: 66
  • Classeur1.xls
    31 KB · Affichages: 68

JeanMarie

XLDnaute Barbatruc
Re : Liste avec mini et maxi

Bonsoir

Bonne année, pour bien la commencer

Formules à valider par les touches Ctrl+Shift+Entrer

Pour la cellule H3
Code:
=SI(OU(H2="";H2=A$183);"";INDEX(A:A;MIN(SI(ESTNA(EQUIV(A$1:A$183;H$2:H2;0));LIGNE(A$1:A$183)));1))
Pour la cellule G3
Code:
=SI(H3="";"";MAX(SI($A$1:$A$183=H3;B$1:B$183)))
Pour la cellule F3
Code:
=SI(H3="";"";MIN(SI($A$1:$A$183=H3;B$1:B$183)))

Une solution en TCD serait plus avantgeuse, mais je n'ai jamais été très copain avec cet assistant.

@+Jean-Marie
 

Pièces jointes

  • Classeur1.zip
    18.1 KB · Affichages: 35
  • Classeur1.zip
    18.1 KB · Affichages: 38
  • Classeur1.zip
    18.1 KB · Affichages: 40
Haut Bas