Formule de comparaison du contenu d'une cellule à une liste

Emman19

XLDnaute Nouveau
Bonsoir à tous,

Tout d'abord merci à tous les contributeurs de ce site qui m'a déjà tellement aidé !
Je fais appel à vous aujourd'hui pour une formule que je n'arrive pas à résoudre :
Je cherche à comparer des cellules dans une colonne dont le contenu complexe de chaque cellule est composé d'une part invariable et d'une part variable.
Je précise que la part invariable ne se trouve pas toujours au début, au milieu ou à la fin de la donnée dans la cellule.

Je cherche à trouver une valeur correspondante à la part variable de la cellule dans une liste dans une autre feuille.

J'ai bien essayé avec des combinaisons de TROUVE, CHERCHE, INDEX et EQUIV mais sans succès !

Je joins un fichier en exemple que j'espère assez clair.

Merci d'avance pour votre aide !
 

Pièces jointes

  • Comparaison_contenu_cellule_a_une liste.xlsx
    9.6 KB · Affichages: 22
  • Comparaison_contenu_cellule_a_une liste.xlsx
    9.6 KB · Affichages: 24
  • Comparaison_contenu_cellule_a_une liste.xlsx
    9.6 KB · Affichages: 22

Amilo

XLDnaute Accro
Re : Formule de comparaison du contenu d'une cellule à une liste

Bonsoir le forum, Emman,

Il y a peut-être plus simple,

Formule matricielle à valider par Alt+Shift+Entrée

{=RECHERCHEV(INDEX(Feuil2!$A$2:$A$8;EQUIV(1;NB.SI(Feuil1!A2;"*"&Feuil2!$A$2:$A$8&"*");0));Feuil2!$A$2:$B$8;2;FAUX)}

Cordialement
 

BOISGONTIER

XLDnaute Barbatruc
Re : Formule de comparaison du contenu d'une cellule à une liste

Bonsoir,

=INDEX(famille;EQUIV(1;NB.SI(A2;"*"&code&"*");0))
Valider avec maj+ctrl+entrée

Formules Matricielles

JB
 

Pièces jointes

  • Comparaison_contenu_cellule_a_une liste.xlsx
    10.2 KB · Affichages: 19
  • Comparaison_contenu_cellule_a_une liste.xlsx
    10.2 KB · Affichages: 22
  • Comparaison_contenu_cellule_a_une liste.xlsx
    10.2 KB · Affichages: 23
Dernière édition:

Emman19

XLDnaute Nouveau
Re : Formule de comparaison du contenu d'une cellule à une liste

Amilo,
Un seul mot : TOP !!!
Je viens d'adapter ta proposition de formule à mon fichier avec les données réelles : excellent !
Me reste plus qu'à comprendre...notamment le "1" en valeur cherchée de EQUIV et les "*" dans NB et le pourquoi de la formule matricielle plutôt qu'une formule classique.
De quoi cogiter cette nuit !
Un grand merci.
Bonne soirée
Emman
 

Amilo

XLDnaute Accro
Re : Formule de comparaison du contenu d'une cellule à une liste

Un grand merci surtout à Boisgontier qui m'avait aidé dans un cas similaire,

Pour la compréhension de la formule, une bonne aide ici

Bonne soirée
 
Dernière édition:

Membres actuellement en ligne

Statistiques des forums

Discussions
287 536
Messages
1 884 452
Membres
163 314
dernier inscrit
cedric.remacle
Haut Bas