1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

formule avec dates

Discussion dans 'Forum Excel' démarrée par Pounet, 11 Janvier 2017.

  1. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
    Bonsoir,
    Je suis coincé sur un problème de formules avec "date" et j’espère que vous allez pouvoir m'aider.
    Je possède un fichier avec un prévisionnel a l'année que j'actualise au fil du temps. J'aimerais avoir une cellule qui comptabilise automatiquement les données des mois terminés au fur et à mesure que l'année avance. Par exemple , au 2 juin, cette cellule compterait les sommes du 1er janvier au 31 mai. Cela doit être possible mais je galère et un peu d'aide serait la bienvenue.
    Ficher joint en PJ pour être tout a fait clair.
    Merci d'avance.
     

    Pièces jointes:

    • essai.xlsx
      Taille du fichier:
      5.6 Ko
      Affichages:
      25
  2. Modeste geedee

    Modeste geedee XLDnaute Barbatruc

    Inscrit depuis le :
    8 Mars 2012
    Messages :
    5890
    "J'aime" reçus :
    705
    Sexe :
    Masculin
    Habite à:
    50.3257, 3.2486
    Utilise:
    Excel 2007 (PC)
    Bonsour®
    en O4 :
    =SOMME(DECALER(B4;0;0;1;MOIS(AUJOURDHUI())))
    recopier vers le bas

    Explication :
    la fonction DECALER permet la somme de la plage depuis la colonne du mois 1 au mois(aujourdhui)
    lorsque le mois(aujourdhui()) sera Août alors la plage sera de 8 cellules
     
    Dernière édition: 11 Janvier 2017
  3. Shakki

    Shakki XLDnaute Occasionnel

    Inscrit depuis le :
    19 Mars 2016
    Messages :
    254
    "J'aime" reçus :
    24
    Utilise:
    Excel 2010 (PC)
    Bonjour,

    Une autre manière de faire à condition que tu transformes tes intitulés "janvier", "février", etc... en vraie date soit 01/01/2017, 01/02/2017, etc... (tu peux ensuite leur donner un format de cellule mmmm si tu le souhaites).

    Code (Text):
    =SOMMEPROD(B4:M4*($B$3:$M$3<=$O$3))
    A+
     
  4. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
    Merci pour cette formule... à laquelle je n'ai pas tout compris.
    Ça fonctionne et c'est bien là le principal.
    J'ai juste besoin de 2 précisions : La formule sera bien valable au changement de mois et le total prend bien du 1er janvier à la date du jour .

    Merci encore.
     
  5. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
    Merci pour cette deuxième solution qui fonctionne bien elle aussi.:)
    Un grand merci a vous . Bonne soirée.
     
  6. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
     
  7. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
    C'est un peu plus clair maintenant avec l'explication de texte.
    Si on veut corser encore, peut-on s’arrêter au dernier jour du mois précedent sans tenir compte du mois en cours?
    Et merci encore.
     
  8. Jacky67

    Jacky67 XLDnaute Impliqué

    Inscrit depuis le :
    12 Juin 2016
    Messages :
    829
    "J'aime" reçus :
    126
    Bonsoir,
    Autre proposition en pj
    Ne tient pas compte du mois en cours si celui-ci n'est pas complet
     

    Pièces jointes:

  9. Pounet

    Pounet XLDnaute Junior

    Inscrit depuis le :
    21 Juillet 2011
    Messages :
    52
    "J'aime" reçus :
    0
    Encore merci, c'est exactement ce que je cherchais. je vais essayer de l’adapter a mon vrai fichier qui est peu plus complexe.Si je tâtonne trop, je reviens vers vous.
     

Partager cette page