XL 2010 Faire une somme en prenant en compte que le premier caractère

anthonygg

XLDnaute Junior
Bonjour,

Pour ma formation, j'ai un tableau où je met le nombre de phrases que j'ai appris par jour en russe.
Je dois arriver à 1000 mots / phrases.

Actuellement j'ai un tableau ou je met seulement le nombre de mots / phrases que j'ai appris. Ex : 12/05/2019 : 2 - Total : 3
J'aimerai maintenant renseigner dans ma case Excel par exemple :
12/09/2019 : 2 - Bonjour - comment ça va ?
13/09/2019 : 1 - Bien

Et que je puisse faire une somme qui me calcule uniquement 2+1=3 mots total.
Si c'est possible ça serait super !
 

Fichiers joints

zebanx

XLDnaute Accro
Bonjour Anthonygg, le forum

Regarde par exemple les formules de Jocelyn :cool: pour extraire l'information sur une colonne.

xl-ment
zebanx
 

vgendron

XLDnaute Barbatruc
Hello
avec une fonction personalisée à mettre dans un module standard
VB:
Public Function nbMot(zone As Range) As Integer


For Each Phrase In zone
    If Trim(Phrase) <> "" Then
        nbMot = nbMot + CInt(Trim(Split(Phrase, "-")(0)))
    End If
Next Phrase
End Function
 

anthonygg

XLDnaute Junior
Bonsoir @anthonygg, @zebanx :), @vgendron :),

Voir formule (en B15) dans le fichier. C'est une formule matricielle.
Super merci la fonction marche ! J'ai bien compris qu'il fallait faire cntrl+maj+entrée.

Cependant j'ai un dernier soucis ! Si je marque "1-" dans le tableau, c'est bon mon calcul fonctionne, mais si je marque seulement 1 ... ça ne marche pas :( Est-ce possible que le calcul puisse accepter les nombres simples ?
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Re,

Essayez la formule (toujours matricielle à valider par Ctrl+Maj+Entrée) :
VB:
=SOMME(SIERREUR(1*GAUCHE(C12:P12;SIERREUR(CHERCHE("-";C12:P12&"-")-1;0));""))
 

anthonygg

XLDnaute Junior
Re,

Essayez la formule (toujours matricielle à valider par Ctrl+Maj+Entrée) :
VB:
=SOMME(SIERREUR(1*GAUCHE(C12:P12;SIERREUR(CHERCHE("-";C12:P12&"-")-1;0));""))
C'est super génial ça marche ! :D Merci beaucoup ça va bien m'aider !
 

Discussions similaires


Haut Bas