1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

extraire le mot qui se trouve toujours entre [ et ]

Discussion dans 'Forum Excel' démarrée par Lanimateur, 12 Novembre 2008.

  1. Lanimateur

    Lanimateur XLDnaute Nouveau

    Inscrit depuis le :
    11 Novembre 2008
    Messages :
    43
    "J'aime" reçus :
    0
    Bonjour, j'ai des cellules qui contiennent des phrases exemple en A11 :

    Nicolas possède un BTS [SMS] et ...

    j'aimerais extraire le mot qui se trouve à chaque fois entre le [ et le ] dans une autre cellule donc pour celle ci le mot est " SMS ".

    Par contre il n'y a pas toujours de [ ] dans certaine cellule donc dans ce cas la, il faudrait que la cellule qui est censé renvoyé le mot ne renvoie rien du tout.

    Merci a ceux qui pourront m'aider :)
     
  2. Chargement...

    Discussions similaires - extraire mot qui Forum Date
    XL 2013 Extraire donnée en fonction d'un mot Forum Excel 7 Octobre 2018
    XL 2013 [Résolu] Extraire un mot dans une chaîne de caractères Forum Excel 9 Mai 2018
    Formule pour extraire mot à droite de plusieurs liens Forum Excel 19 Novembre 2015
    XL 2013 Extraire des mots uniques d'une colonne à une liste avec le compte en nombre Forum Excel 21 Août 2015
    vba- extraire un mot dans une phrase sous condition Forum Excel 30 Mai 2015

  3. Staple1600

    Staple1600 XLDnaute Barbatruc

    Inscrit depuis le :
    24 Juin 2005
    Messages :
    24536
    "J'aime" reçus :
    1080
    Habite à:
    Roahzon
    Utilise:
    Excel 2013 (PC)
    Re : extraire le mot qui se trouve toujours entre [ et ]

    Bonsoir

    Un début de réponse

    Si en A1
    Nicolas possède un BTS [SMS]

    En B1, saisir la formule suivante
    Code (Text):
    =SUBSTITUE(SUBSTITUE(STXT(A1;CHERCHE("[";A1);CHERCHE("]";A1));"[";"");"]";"")
     
  4. Pierrot93

    Pierrot93 XLDnaute Barbatruc

    Inscrit depuis le :
    1 Août 2006
    Messages :
    22334
    "J'aime" reçus :
    428
    Utilise:
    Excel 2010 (PC)
  5. ninbihan

    ninbihan XLDnaute Impliqué

    Inscrit depuis le :
    26 Mars 2007
    Messages :
    592
    "J'aime" reçus :
    0
    Habite à:
    Nantes
    Utilise:
    Excel 2016 (PC)
    Re : extraire le mot qui se trouve toujours entre [ et ]

    Bonsoir L'animateur, Staple et Pierrot,
    Bonsoir le forum

    Avec STXT en B11:
    Code (Text):
    =STXT(A11;CHERCHE("[";A11)+1;CHERCHE("]";A11)-CHERCHE("[";A11)-1)
    Bonne soirée à tous,

    Ninbihan
     
  6. jp14

    jp14 XLDnaute Barbatruc

    Inscrit depuis le :
    15 Décembre 2005
    Messages :
    3637
    "J'aime" reçus :
    19
    Utilise:
    Excel 2010 (PC)
    Re : extraire le mot qui se trouve toujours entre [ et ]

    Bonjour

    Ci dessous une formule
    Le texte étant en A4
    =SI(ESTERREUR(CHERCHE("[";A4;1)>1);"";STXT(A4;CHERCHE("[";A4;1)+1;CHERCHE("]";A4;1)-CHERCHE("[";A4;1)-1))

    A tester

    JP
     
  7. abcd

    abcd XLDnaute Barbatruc

    Inscrit depuis le :
    23 Décembre 2007
    Messages :
    2896
    "J'aime" reçus :
    5
    Re : extraire le mot qui se trouve toujours entre [ et ]

    Bonsoir,

    Partant de l'hypothèse que la chaine de caractère entre [] ne se trouve pas nécessairement à l'extrême droite, par exemple BTS [SMS] alm

    =SI(ESTNUM(CHERCHE("[";A1));STXT(A1;CHERCHE("[";A1)+1;CHERCHE("]";A1)-CHERCHE("[";A1)-1);"")

    abcd
     
  8. Staple1600

    Staple1600 XLDnaute Barbatruc

    Inscrit depuis le :
    24 Juin 2005
    Messages :
    24536
    "J'aime" reçus :
    1080
    Habite à:
    Roahzon
    Utilise:
    Excel 2013 (PC)
    Re : extraire le mot qui se trouve toujours entre [ et ]

    Re à tous

    J'avais compliqué inutilement (lol)

    Une autre piste sans formule

    Utiliser Données/Convertir

    EDITION: macro modifiée

    Code (Text):

    Sub Macro1bis()
    Range("A1:A" & [A65536].End(xlUp).Row).Copy Range("B1")
    Range("B1:B" & [B65536].End(xlUp).Row).TextToColumns Destination:=Range("B1"), DataType:=xlDelimited, _
            TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=True, _
            Semicolon:=False, Comma:=False, Space:=False, Other:=True, OtherChar _
            :="[", FieldInfo:=Array(Array(1, 9), Array(2, 1))
    Range("B1:B" & [B65536].End(xlUp).Row).TextToColumns Destination:=Range("B1"), DataType:=xlDelimited, _
            TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=True, _
            Semicolon:=False, Comma:=False, Space:=False, Other:=True, OtherChar _
            :="]", FieldInfo:=Array(Array(1, 1), Array(2, 9))
    End Sub
     
    Voici ce que cela donne en utilisant l'enregistreur de macro
    Code (Text):
    Sub Macro1()
    '
    ' Macro1 Macro
    ' Macro enregistrée le 12/11/2008
    '

    '
        Range("A1:A17").Select
        Selection.Copy
        Range("B1").Select
        ActiveSheet.Paste
        Application.CutCopyMode = False
        Selection.TextToColumns Destination:=Range("B1"), DataType:=xlDelimited, _
            TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=True, _
            Semicolon:=False, Comma:=False, Space:=False, Other:=True, OtherChar _
            :="[", FieldInfo:=Array(Array(1, 9), Array(2, 1))
        Selection.TextToColumns Destination:=Range("B1"), DataType:=xlDelimited, _
            TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Tab:=True, _
            Semicolon:=False, Comma:=False, Space:=False, Other:=True, OtherChar _
            :="]", FieldInfo:=Array(Array(1, 1), Array(2, 9))
    End Sub
     
     
    Dernière édition: 12 Novembre 2008
  9. Lanimateur

    Lanimateur XLDnaute Nouveau

    Inscrit depuis le :
    11 Novembre 2008
    Messages :
    43
    "J'aime" reçus :
    0
    Re : extraire le mot qui se trouve toujours entre [ et ]

    merci a tous pour vos réponses :)

    ça marche niquel sans utiliser la macro :)
     

Partager cette page