Résolu Extraction valeur dernier jour du mois

GUY rrr

XLDnaute Junior
Bonjour le forum,

Me revoici à redemander une fois de plus un coup de main ...:).
Je cherche à extraire la dernière valeur du dernier jour du mois de janvier, février ... mais n'arrive pas à le faire "automatiquement" ...
Je joins un fichier exemple avec ce que j'ai pu effectuer :confused:.

Merci aux personnes qui prendront le temps de se pencher sur ma problématique.

Cordialement
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Avec une formule matricielle
VB:
=SIERREUR(INDEX($F$8:$F$18;GRANDE.VALEUR(SI(MOIS($A$8:$A$18)=MOIS(1&$A1);LIGNE($A$8:$A$18)-7);1));"-")
copier vers le bas

JHA
 

Fichiers joints

GUY rrr

XLDnaute Junior
Bonsoir riton00, JHA ;), le forum,

Merci pour vos réponses rapides.
@riton00, votre proposition correspond à ma demande même si j'efface tout ce qu'il y a après la ligne 13. Idéalement, j'aurais souhaité en une seule formule :cool:.
@JHA, votre proposition en une seule formule me correspondrait mais ... les résultats attendus ne sont pas ceux souhaités :( si j'efface à partir de la ligne 13.

Merci pour vos propositions
 

GUY rrr

XLDnaute Junior
Bonsoir JM27, sylvanu, riton00, JHA ;), le forum,

Que de propositions :D ... je n'ai plus qu'à choisir.
Un grand MERCI à tous les intervenants pour vos solutions ;).

Très bonne soirée.
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Pour prendre les vides en compte.

VB:
=SIERREUR(INDEX($F$8:$F$18;GRANDE.VALEUR(SI(MOIS($A$8:$A$18)=MOIS(1&$A1)*($A$8:$A$18>0);LIGNE($A$8:$A$18)-7);1));"-")
JHA
 

GUY rrr

XLDnaute Junior
Bonsoir JHA,

Vos formules fonctionnent mais lorsque j'agrandis les plages de recherche (par exemple $F$8:$F$18 en $F$8:$F$180 ainsi que la plage de la colonne A) la formule ne renvoie pas les résultats attendus ...
Avez-vous une idée de ce qu'il se passe ?

Merci pour votre retour
 

GUY rrr

XLDnaute Junior
Bonsoir JHA, le forum,

Je crois avoir trouvé, c'est mon Etc ... qui perturbait le processus ...
et j'ai changé

=SIERREUR(INDEX($F$8:$F$18;GRANDE.VALEUR(SI(MOIS($A$8:$A$18)=MOIS(1&$A1)*($A$8:$A$18>0);LIGNE($A$8:$A$18)-7);1));"-")

par

=SIERREUR(INDEX($F$8:$F$18;GRANDE.VALEUR(SI(MOIS($A$8:$A$18)=1*($A$8:$A$18>0);LIGNE($A$8:$A$18)-7);1));"-")


Voili voilou

Bonne soirée
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas