XL 2016 Extraction date selon valeur

CASSIN

XLDnaute Nouveau
Bonjour,
Grace a cette formule:

=SI(BRICE!P15="ASTREINTE";JOUR(BRICE!B15);"")

Le resultat de ma cellule est "15" (car ca correspond au 15 juin)

est il possible de cumuler les résultats ds la même cellule ?

J'ai essayé =SI(BRICE!P15="ASTREINTE";JOUR(BRICE!B15);"");=SI(BRICE!P16="ASTREINTE";JOUR(BRICE!B16);"")

L'idée est d'affiche l'extraction de plusieurs jours dans la meme cellule, séparés par virgule, point tirer ou peu importe ...

Merci
 

Roblochon

XLDnaute Accro
Bonjour,

Vous pouvez toujours essayer :
=SI(BRICE!P15="ASTREINTE";JOUR(BRICE!B15);"") & SI(BRICE!P16="ASTREINTE";"/" & JOUR(BRICE!B16);"")

Mais sans fichier pour valider, difficile d'aller plus loin
bonne soirée
 

CASSIN

XLDnaute Nouveau
Bonjour,
Ça fonctionne très bien, merci.
Voici ma formule complète:

=SI(BRICE!P8="ASTREINTE";JOUR(BRICE!B8);"")
& SI(BRICE!P9="ASTREINTE";"/" & JOUR(BRICE!B9);"")
& SI(BRICE!P15="ASTREINTE";"/" & JOUR(BRICE!B15);"")
& SI(BRICE!P16="ASTREINTE";"/" & JOUR(BRICE!B16);"")
& SI(BRICE!P22="ASTREINTE";"/" & JOUR(BRICE!B22);"")
& SI(BRICE!P23="ASTREINTE";"/" & JOUR(BRICE!B23);"")
& SI(BRICE!P29="ASTREINTE";"/" & JOUR(BRICE!B29);"")
& SI(BRICE!P30="ASTREINTE";"/" & JOUR(BRICE!B30);"")

Est elle simplifiable ? en indiquant une colonne ocmlplete par exemple en P et B ?

Sachant que je dois faire ca pour 11 salariés donc 11 feuilles est ce que je dois changer les noms des feuilles un par un, ou ya t-il un raccourci ?
Cdlt
 

Roblochon

XLDnaute Accro
Bonjour,

Oui, il y a certainement plus simple, mais donnez nous un fichier exemple anonymisé et avec des données bidons (au premier message c'eût été super).
Le fichier doit bien refléter votre demande.

Cordialement
 

CASSIN

XLDnaute Nouveau
Bonjour
Merci pour votre réponse.
Je vous joint le fichier complet, aucun nom n'y figure.
J'ai mis quelques notes sur la feuille VARIABLES!
Mes tests sont fait sur les feuilles BRICE! et VARIABLES!

J'essai donc d'indiquer les jours correspondant a des astreintes
sur BRICE! en colonne P dans les cellules correspondant a des week end, j'ai fait en sorte que si la cellule de la meme ligne en H n'est pas vide, ca m'affiche ASTREINTE
Puis sur VARIABLES! en F, je fais apparaitre les jours du mois qui correspondent aux cellules "ASTREINTE"
Les problemes
- J'ai un tiret qui apparait avant mes jours
- Je dois appliquer cette formule a chaque technicien donc a chaque feuille,
- Ma formule est très longue, je cherche a la simplifier

Je vous remercie pour votre aide
Jerome
 

Fichiers joints

Roblochon

XLDnaute Accro
Bonjour,

En pièce joint une fonction personnalisée (VBA) nommée JoursAstreinte et utilisée dans la feuille Variables de F3 à F13.
Le séparateur des jours par défaut est le "-" mais peut être changé.
Exemple avec point-virgule comme séprarateur: =JourAstreinte(A3;";")

Cordialement
 

CASSIN

XLDnaute Nouveau
Jai bien un message me demandant d activer les macros, mais ensuite je n'ai aucune macro ?
Jai du mal avec VBA ^^
 

Roblochon

XLDnaute Accro
Re,

ALT+F11 (pour ouvrir la fenêtre de l'éditeur VBA) ou onglet Développeur/bouton 'Visual Basic'.
Si l'onglet développeur n'est pas affiché: click-droit sur une zone libre du ruban puis 'Personaliser le ruban' et dans la fenêtre qui s'ouvre dans la colonne droite (onglets principaux) cochez 'Développeur'


Cordialement
 

Discussions similaires


Haut Bas