XL 2016 extraction jours selon remplissage cellule

CASSIN

XLDnaute Nouveau
Bonjour le forum.
Je cherche le moyen d'extraire des jours depuis une cellule date en fonction du remplissage d'une autre cellule
C'est beaucoup plus simple à comprendre avec le fichier sous les yeux !

En gros


En colonne A: " Lundi 29 avril 2019" "Mardi 30 avril 2019" ETC...
En colonne B: "OK" ou rien
En C3: =SI(NB.SI(B3:B13;"*OK*");JOUR(A3);"")

Cette formule fonctionne très bien pour un jour: Si OK est indiqué en B3, "29" apparaît en C3

Simplement je dois arriver a ce que C3 puisse afficher plusieurs jours à la suite ( séparés par peu importe quel caractère), en fonction de ce qui est indiqué dans la colonne B (OK ou rien)


Reste à savoir si c'est faisable ^^
Merci d'avance pour votre aide,
Jerome
 

Fichiers joints

frangy

XLDnaute Occasionnel
Bonjour,

Voici une solution avec une fonction personnalisée.
Rq : le fait d'afficher simplement le jour ne permettra pas de différencier 29/04 et 29/05.

Cordialement.
 

Fichiers joints

CASSIN

XLDnaute Nouveau
Ah oui merci de cette précision.
Mais en fait l'utilisation finale est d'automatiser les congés et absences, donc du 1er au 30/31 :)
Je teste dessuite Merci
 

CASSIN

XLDnaute Nouveau
Merci pierrejean, Existe t-il une solution sans Macros?
Ou dans le cas ou ce soit trop complexe, est ce que je peux fournir mon vrai fichier dans lequel je dois inclure cette formule ?
Car par exemple a la place de OK ce sera "C" mais il pourra aussi y avoir "A" qui se reportera de la même manière dans une autre cellule .

De plus, les cellules "sources" sont sur une feuille différente ^^
 

CASSIN

XLDnaute Nouveau
Ne connaissant pas les VBA, j'ai voulu tester:
- J'ai créé un deuxieme module idem au premier mais modifié comme suite :


Function joursNON(zone As Range)
For Each cel In zone
If cel = "NON" Then
jours = jours & Format(cel.Offset(0, -1), "d") & ","
End If
Next
joursNON = Left(jours, Len(jours) - 1)
End Function


J'ai ensuite mis dans ma cellule : =joursNON(A2:B35)

Mais ca met #VALEUR!

J'imagine que j'oublie quelque chose ou que je suis totalement a coté de la plaque?
 

pierrejean

XLDnaute Barbatruc
Re
Je ne saurais le faire autrement qu'en Vba (macro)
Avec le vrai fichier avec des données anonymisées on pourra te trouver une solution
 

CASSIN

XLDnaute Nouveau
Ci joint le fichier j'ai enlevé les noms de famille.

J'ai mis des notes dans les cellules concernées sur la feuille "variables", les autres feuilles concernées sont "modèle" et "Brice"


Une question bete (premiere fois que j'ai a faire aVBA)
C'est inclu dans le fichier excel, ou le fichier n'est valable que sur le PC sur lequel il se trouve ?

Car j'ai remarqué que la meme fenetre VBA s'ouvre peu importe le fichier excel ouvert ...)

CDlt
 

Fichiers joints

CASSIN

XLDnaute Nouveau
Bonjour
De retour de congés ( oui oui 3 semaines ...)
Je relance le sujet, Si quelqu'un a une solution a me proposer concernant les notes que j'ai mises dans les cellules du fichier joint plus haut ?
Merci
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas