différence entre 2 cellules selon plusieurs conditions

Frank Bellaisch

XLDnaute Nouveau
Bonjour à tous
et merci d'avance pour votre aide. Je n'ai déjà plus de cheveux tellement j'ai cherché (il faut accepter ses propres limites !!!)

Voila, j'ai une base de données où mes collaborateurs saisissent le volume de carburant acheté et notentla date correspondant, le kilométrage au moment du plein d'essence et l'immatriculation. C'est une fichier partagé donc au fil des jours, le tableau se remplit mais pas forcément dans l'ordre.
Pour calculer les consommations (l/100 km) pour chaque véhicule, il faut bien que je puisse calculer la différence de km parcourus entre 2 remplissages de réservoirs.
J'aimerais donc qu'à chaque fois qu'on croise la même immatriculation avec la date immédiatement supérieure à la précédente pour cette même immat, on calcule la différence entre les relevés compteur ou on inscrit dans une colonne supplémentaire le relevé du compteur immédiatement antérieur. Par différence, j'aurai donc les km parcourus depuis le dernier plein.
Je ne sais pas si je suis clair. Merci
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Sans fichier exemple, difficile de te donner une solution représentant ton soucis.
As-tu essayé avec somme.si() ou max (si())

JHA
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut-être en "E5" (formule matricielle):
Code:
=SI(NB.SI($B$5:$B5;$B5)>1;MAX(SI($B$4:$B4=$B5;$C$4:$C4));"")
et en "F5"
Code:
=SI(NB.SI($B$5:$B5;$B5)>1;$C5-$E5;"")
JHA
 

Fichiers joints

Discussions similaires


Haut Bas