Autres Detecter les doublons

guellila

XLDnaute Nouveau
bonjours
votre support svp pour une formule qui me permet de détecter les doublons parfois sur mon tableau j'ai des données qui sont en double mais qu'il ne sont pas dans le même ordre mais ils sont considéré comme des valeurs double exemple le tableau ci-dessous les données qui se trouve a coté de la cellule AB et la même que les données qui se trouve a coté de la cellule BA même cas pour les deux autres ligne au dessous



Modem Port Name
NE NameNE Name
ABADT05.1-AD0128.1ADT05.1AD0128.1
BAAD0128.1-ADT05.1AD0128.1ADT05.1
RE4892.1-RET10.2_VRE4892.1RET10.2
RET10.2-RE4892.1_VRET10.2RE4892.1

cdt
 

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous,
@Djidji. Vous trouvez les lignes 8 et 310 uniques alors que pour moi elles ne le sont pas :
Ligne 8:
SI-POS01-SI2204SI2290-POS01SI2204SI2204-SI2290-POS01unique
Ligne 310 :
SI2204-SIPOS01SI2204SI2290-POS01SI2290-POS01-SI2204unique

Enfin d'après ce que j'ai compris, un doublon est quand les deux NE name sont identiques, même si inversés.
 

djidji59430

XLDnaute Barbatruc
Oui, c'est subtil !
Je ne suis pas allé jusque la.
Et la question mérite d"être posée et aura sa réponse, je l'espère, par Guelilla.

Crdlmt
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Dans le tableau de Guelilla, il y a l'exemple du doublon AB BA:
1.jpg
C'est la dessus que je me suis basé, d'où le VBA.
Ce qui est sur c'est que Guelilla à la solution quelque soit son approche. :D
 

guellila

XLDnaute Nouveau
Bonjour à tous,
@Djidji. Vous trouvez les lignes 8 et 310 uniques alors que pour moi elles ne le sont pas :
Ligne 8:
SI-POS01-SI2204SI2290-POS01SI2204SI2204-SI2290-POS01unique
Ligne 310 :
SI2204-SIPOS01SI2204SI2290-POS01SI2290-POS01-SI2204unique

Enfin d'après ce que j'ai compris, un doublon est quand les deux NE name sont identiques, même si inversés.
Bonjour Sylvanu
exactement un doublon c'est quand Jai de NE Name identique même si ils sont inversé , je voudrais aussi supprimer ces doublons et garder seulement une valeur unique même si le nom est inversé

cdt
 

job75

XLDnaute Barbatruc
Bonjour guellila, sylvanu, djidji59430,

Les 2 colonnes NE Name étaient plus nuisibles qu'autre chose, je les ai supprimées.

Voyez le fichier joint et cette formule en B2 :
Code:
=SI((NB.SI(T;A2)>1)+ESTNUM(EQUIV(STXT(A2;TROUVE("-";A2)+1;99)&"-"&GAUCHE(A2;TROUVE("-";T)-1);T;0));1;"")
Le nom T étant défini sur le tableau structuré A2:B355.

La suppression des doublons se fait très simplement sans VBA.

A+
 

Fichiers joints

Dernière édition:

guellila

XLDnaute Nouveau
merci Job75
si j'ai bien compris la formule détecte les doublons , svp comment faire pour garder une seule valeur et éliminer la deuxième qui est en double

cdt
 

job75

XLDnaute Barbatruc
En remplaçant les tirets bas _ par des tirets - en colonne A on obtient 12 doublons supplémentaires.
 

job75

XLDnaute Barbatruc
Voyez ce fichier (2) et cette formule en B2 :
Code:
=SI((LIGNE()>1+EQUIV(A2;T;0))+ESTNUM(LN(LIGNE()>1+EQUIV(STXT(A2;TROUVE("-";A2)+1;99)&"-"&GAUCHE(A2;TROUVE("-";A2)-1);T;0)));1;"")
Seuls les doublons au-delà de la 1ère occurrence sont repérés.
 

Fichiers joints

Dernière édition:

job75

XLDnaute Barbatruc
Il n'est pas nécessaire que les formules en B2 soient matricielles, j'ai corrigé mes posts #12 et #17.

Bonne nuit.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas