Des "SI" toujours des "SI"

K

K

Guest
Salut à vous,

Une question portant sur la fonction "SI" :

Je souhaite établir un corrigé automatique suite à une série de QCM :

Parfois, une question peut amener plusieurs réponses correctes, et je ne parviens pas à trouver la bonne formule pour centraliser cela dans ma feuille de résultats :

J'ai essayé si(A1;A2;A3="X";"ok";"erreur").

autant cela marche sur un suite de cellule :
si(A1:A5="x"......)

Mais pas sur une suite de cellules précises......

Coment faire ?? merci d'avance.

K.
 
A

andré

Guest
Salut K,

=SI(ou(A1="x";A2="X";A3="X");"ok";"erreur")

Bonne soirée.
André.
 
K

K

Guest
Aïe !!

Suite.....................

Autre bug de mon fichier !

Dans les cellules permettant de répondre aux questions (4 choix en moyenne par question), je me suis rendu compte que, si les candidats répondent en mettant une croix dans toutes les cellules...........

>> "OK" apparait dans la fiche de résultats sur la ligne relative à la question concernée.......... Autrement dit, si ils cochent toutes les cases du document : "ils ont tous gagnés" !!

Help....;

Dur, dur !!!

Désolé pour mon modeste niveau !!!

K.
 
A

andré

Guest
Salut K,

Si tu peux déterminer le nombre maximum de "X" que les candidats peuvent placer, tu emploies en complément les fonctions ET et NB.SI, ce qui devrait faire ressembler ta formule à quelque chose comme suit :

=SI(ET(OU(A1="X";A2="X";A3="X");NB.SI(ta plage;"X")<ton nombre maximum de "X");"ok";"erreur")

Je te laisse vérifier, je ne l'ai pas testée.



André.
 

Discussions similaires


Haut Bas