XL 2003 % de chiffres positifs par rapport aux chiffres négatifs

Jean-Patrick

XLDnaute Nouveau
Bonjour,

Je souhaiterai calculer en pourcentage le nombre de chiffres positifs par rapports au nombre de chiffres négatifs. Je ne sais pas si c'est très clair.
J'ai dans un tableau Excel, des chiffres positifs (bonne chose) et des chiffres négatifs (mauvaise chose). Je voudrai calculer le pourcentage de chiffre dans les deux cas, peu importe le chiffre positif ou négatif. Ce qui m'intéresse c'est combien il y en a de négatif et combien il y en a de positif.

J'ai essayé les formules suivantes:

=NBVAL(SI(A1;A100;">0"))
=NBVAL(SI(A1;A100;"<0"))

Pour ensuite faire un pourcentage entre ces deux cellules, sans succès.

Pouvez-vous m'aider?
 

Modeste geedee

XLDnaute Barbatruc
Bonjour,

Je souhaiterai calculer en pourcentage le nombre de chiffres positifs par rapports au nombre de chiffres négatifs. Je ne sais pas si c'est très clair.
J'ai dans un tableau Excel, des chiffres positifs (bonne chose) et des chiffres négatifs (mauvaise chose). Je voudrai calculer le pourcentage de chiffre dans les deux cas, peu importe le chiffre positif ou négatif. Ce qui m'intéresse c'est combien il y en a de négatif et combien il y en a de positif.

J'ai essayé les formules suivantes:

=NBVAL(SI(A1;A100;">0"))
=NBVAL(SI(A1;A100;"<0"))

Pour ensuite faire un pourcentage entre ces deux cellules, sans succès.

Pouvez-vous m'aider?
=NB.SI(A1:A100;">0")/NB.SI(A1:A100;"<0")
 
Dernière édition:

Marjo2

XLDnaute Junior
Nouveau
Pour compter le nombre de cellule supérieur à 0 : NB.SI(A:A;">0")
Pour compter le nombre de cellule inférieur à 0 : NB.SI(A:A;"<0")

Pour avoir le nombre de cellule inférieur à 0 sur le total : NB.SI(A:A;"<0")/NBVAL(A:A)

NB.SI = compte sous condition si
NBVAL = compte le nombre de cellule non vide
 

Discussions similaires


Haut Bas