Résolu Compatibilité matrice fonction Decaler ou Index

VLMX

XLDnaute Nouveau
Bonjour,

J'ai un problème de compatibilité avec la fonction "Décaler" ou "Index" sur un poste, je ne sais pas si vous avez déjà eu le problème et est ce que vous l'avez résolu ?
je créer une liste en supprimant les doublons / espace et je trie cette liste de A/Z, cela fonctionne parfaitement sur la plus part des postes informatique sauf sur 1 . . .

voici la formule qui pose problème :
=SIERREUR(INDEX(PLAGEnommé;DECALER(PLAGEnommé;EQUIV(VRAI;INDEX(PLAGEnommé<>"";0);0)-1;0;NBVAL(PLAGEnommé)-NB.VIDE(PLAGEnommé))+1;0);"")

Vous pourrez voir les termes utilisé, j'ai volontairement remplacé la plage utilisé par "PLAGEnommé"
Je voulais éviter de passer par du VBA.

Je ne sais pas si ce poste va faire doublon mais étant donner que je ne connait pas vraiment les termes j'ai du mal à le trouver.

Merci d'avance,

Cordialement
 

VLMX

XLDnaute Nouveau
En fait c'est la création de la liste qui ne se fait pas ... comparé au autres postes, cela renvoi uniquement la première valeur de la liste ...
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Formule à essayer en "A2" elle gère les doublons:
VB:
=SIERREUR(INDEX(Plage;EQUIV(0;INDEX(NB.SI($A$1:$A1;Plage););0));"")
copier vers le bas

Autrement, peux-tu mettre un exemple sur fichier car la formule suivant ne gère pas les doublons:
Code:
=DECALER(plage;EQUIV(VRAI;INDEX(plage<>"";0);0)-1;0;NBVAL(plage)-NB.VIDE(plage))
JHA
 
Dernière édition:

VLMX

XLDnaute Nouveau
Bonjour merci pour votre réponse, j'ai pas encore fait les tests mais je vais essayer, voici le fichier excel avec un exemple de ma formule et de mon utilisation
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Formule pour la liste sélectionnée modifiée, en "B3":
VB:
=SIERREUR(PETITE.VALEUR(DECALER($C$2;1;EQUIV($B$2;$D$2:$Q$2;0);17);LIGNE(1:1));"")
Copier vers le bas

JHA
 

Fichiers joints

VLMX

XLDnaute Nouveau
Bonjour à tous,

Et bien ... très belle solution, merci
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas