Résolu Office 365 Classer des cellules combinant texte et date

Matsramgram

XLDnaute Nouveau
Bonjour
Je cherche à faire qqchose de simple a priori.
J'ai une liste de dates en colonne A
J'ai une liste de noms en colonne C, où le même nom peut apparaître plusieurs fois à des dates différentes.
J'ai donc un certain nombre d'occurrences d'un même nom, correspondant à des dates uniques.
Je voudrais numéroter chaque nom de la façon suivante : xyNom, où x représente la xème fois où apparaît le nom par rapport à la date (en ordre chronologique : 1 = l'occurrence la plus ancienne), et y le nombre total d'occurrences du nom.
Dans la colonne D apparaît une tentative d'obtenir ce résultat : y est facile à définir, mais je n'arrive pas à trouver de formule pour x. Je n'arrive pas à incrémenter x en suivant un ordre chronologique, la formule partant du principe que la table est déjà classée par ordre chronologique.
Merci d'avance à ceux qui pourraient m'aider (en colonne F, le résultat souhaité, avec les différence par rapport à la formule actuelle).
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Matsramgram,

Tu peux essayer en E2 :

VB:
=NB.SI($C:$C;$C2)-NB.SI($C$1:C1;C2)&" sur "&NB.SI($C:$C;$C2)
Cordialement
 

Matsramgram

XLDnaute Nouveau
Merci bcp Jocelyn pour ta rapidité !
J'ai essayé la formule, mais ça ne marche pas dans tous les cas : quand on trie par ordre anti-chronologique (puis par nom, etc) cela marche. Mais quand on trie par ordre chronologique (puis/ou date de sortie, nom etc) cela ne donne pas le résultat souhaité.
J'ai mis en couleur conditionnelle les cellules qui ne renvoient pas le bon résultat dans ta formule.
Any other idea??
 

Fichiers joints

Matsramgram

XLDnaute Nouveau
Bonjour Matsramgram, Jocelyn,

Un essai sur le fichier joint.

Cordialement
Hello
Woow ça m'a l'air de marcher parfaitement. Merci bcp haonv (et Jocelyn).
En plus je découvre qu'on peut donner directement à une cellule un nom qui est celui de son contenu, c'est bien ça ?
Merci encore. PS : forum balaise et réactif !
 

Matsramgram

XLDnaute Nouveau
Hello
Woow ça m'a l'air de marcher parfaitement. Merci bcp haonv (et Jocelyn).
En plus je découvre qu'on peut donner directement à une cellule un nom qui est celui de son contenu, c'est bien ça ?
Merci encore. PS : forum balaise et réactif !
Je veux dire qu'une plage peut prendre automatiquement le nom de la première cellule ? ou j'ai raté qq chose ?
 

haonv

XLDnaute Occasionnel
Bonjour,

En fait, on nomme une plage dans le gestionnaire de noms.
Ici, avec la fonction décaler. Ce qui permet un ajustement de la plage lorsque des nouvelles données sont entrées.



Capture gestionnaire de noms.PNG
Cordialement
 
Ce message a été identifié comme étant une solution!

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas