XL 2016 Changer une donnée (Année) dans plusieurs formule en même temps

Phoenix23

XLDnaute Occasionnel
Bonjour à toutes et tous.
Ma question concerne le changement d'une donnée sur des formules type ci dessous..
Dans le but par exemple de remplacer l'année 2019 par 2020, en une seule fois sur toutes les formules.
Actuellement lorsque je veux modifier l'année, soit manuellement je supprime le "19" et le remplace par "20", ce qui implique de de reprendre toutes les formules une par une, ou une fois la première ligne modifiée je sélectionne la partie de la formule modifiée et je fais un copier,coller sur toutes les autres formules, mais cela implique de les modifier Egalement une à une..

=NB.SI('2019'!$C$6:$C$597;"*a*")
=NB.SI('2019'!$C$6:$C$597;"*b*")
=NB.SI('2019'!$C$6:$C$597;"*c*")
=NB.SI('2019'!$C$6:$C$597;"*d*")
D'avance Merci.
Cordialement.
 

Staple1600

XLDnaute Barbatruc
Bonjour le fil, Phoenix23

Victor21 (Salutations)
Chez moi ALT L affiche les lettres sur le ruban
(Testé sur XL2013)
Sélection des cellules contenant les formules puis
CTRL+H
2019
2020
ALT+A
 

Victor21

XLDnaute Barbatruc
Supporter XLD
Re,

Et quel est l'avantage par rapport à CTRL+H?
(la navigation dans les options?)
Qui parle d'avantage (davantage ?)
Ce n'est qu'une alternative parmi d'autres (renommer la feuille 2019 par ex) .
;)
Dans le cas de Phoenix23, prévoyant que le fichier serait susceptible de servir plusieurs années, j'aurais pour ma part créé les formules avec la date en paramètre (référence ou nom défini).
 

Staple1600

XLDnaute Barbatruc
Re

Personne.
Je cherchais juste à comprendre pourquoi tu ne passais par CTRL+H
(Je pensais à tort qu'il devrait y avoir un avantage à tes raccourcis claviers que je n'avais pas capté)
D'où ma question ;)
 

Phoenix23

XLDnaute Occasionnel
Staple 1600, Victor 21.
Bonjour, Merci pour vos réponses.
Grace à vous la mise à jour de mes fichiers va être beaucoup moins fastidieuse...
Cordialement
 

Claudy

XLDnaute Impliqué
Bonsoir,
et pourquoi pas indirect et une référence absolue exemple $A$1 où A1= ton année?
A+
claudy
 

Roblochon

XLDnaute Accro
Bonsoir chacun,

Créer un nom 'PrmAnnee' avec pour formule = 2020

Puis comme mes petits camarades sélectionner mes cellules contenant les formule CTRL+H et remplace 2019 par PrmAnnee

A+
 

Claudy

XLDnaute Impliqué
Un peu dans le genre:
=NB.SI(INDIRECT($A$1&"!"&"i4:i150";VRAI);"*a*")
à adapter chez toi...

A+
Claudy
 

Eric C

XLDnaute Accro
Bonsoir le forum
Bonsoir le fil

Tu n'y es pas Staple1600 - Notre ami Robochon (;)) a utilisé l'acronyme (Prm) qui sous entendait "Petit roblochon malin"....
Bonne fin de dimache
@+ Eric c
 

Roblochon

XLDnaute Accro
Re,
Tu n'y es pas Staple1600 - Notre ami Robochon (;)) a utilisé l'acronyme (Prm) qui sous entendait "Petit roblochon malin"....
Ma modestie m'empêchait de le dire...arf:cool:

Mais je suis content d'avoir gagné un nouveau jour:
Bon dimache à toi oussi Eric:)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas