Calculer une somme de mots dans une colonne par rapport à une autre liste

Barbapapa

XLDnaute Occasionnel
Bonjour à tous, je cherche une formule me permettant de calculer le nombre de mots contenus entre 2 cellules d'une colonne si ces mots font partis d'une liste prédéfinis située à un autre endroit.
J'ai cherché mais rien à faire... j'ai pas trouvé.
Je vous joints un fichier pour plus de clarté.
Merci à tous
Frédéric
 

Fichiers joints

Barbapapa

XLDnaute Occasionnel
Re : Calculer une somme de mots dans une colonne par rapport à une autre liste

Merci JBARBE, mais ce n'est pas ce que je cherche. Je souhaite que la formule fasse une comparaison avec la liste nommée "noms".
Bonne journée
 

JNP

XLDnaute Barbatruc
Re : Calculer une somme de mots dans une colonne par rapport à une autre liste

Bonjour le fil :),
Si VBA ne te dérange pas, une fonction personnalisée
Code:
Function CompteNoms(Plage As Range, Réf As Range) As Integer
Dim Cellule As Range, Recherche As Range
For Each Cellule In Plage
Set Recherche = Réf.Find(Cellule, lookat:=xlWhole, LookIn:=xlValues)
If Not Recherche Is Nothing Then CompteNoms = CompteNoms + 1
Next
End Function
Bonne suite :cool:
 

Fichiers joints

Barbapapa

XLDnaute Occasionnel
Re : Calculer une somme de mots dans une colonne par rapport à une autre liste

Merci à tout les deux, je préfère une formule par rapport à ce que je suis entrain de faire.
Mais j'ai fini par trouver... {=SOMME(NB.SI(A1:A10;noms))}
Bonne journée à tous
 

Discussions similaires


Haut Bas