Calculer nombre de jours + heures/minutes/secondes par rapport à 2 dates

benbeto

XLDnaute Nouveau
Bonjour,

J'aurais besoin d'aide car je suis pas doué sur excel malheureusement :(
Je vous explique ce que je souhaite faire :

3 colonnes A B et C
Dans la colonne A j'ai une date (date réception du courrier par exemple)
Dans la colonne B j'ai une date également (date d'envois du courrier)
Dans la colonne C j'aimerais avoir le nombre de jours, heures, minutes écoulées entre ces 2 dates

Exemple

Colonne A Colonne B Colonne C
17/07/2012 09:12 26/07/2012 10:20 9 jours 1h et 8 minutes

Avec les formules proposées je peux simplement ressortir l'info avec le format suivant 9/1/00 1:08

Merci par avance pour votre aide
 

Gurgeh

XLDnaute Occasionnel
Re : Calculer nombre de jours + heures/minutes/secondes par rapport à 2 dates

Salut benbeto,

La formule C = B - A va effectivement te donner la bonne valeur, (9/1/00 1:08, cela correspond bien à 9 jours 1h et 8 minutes). Si j'ai bien compris, ton souci est uniquement d'avoir ça dans un format plus agréable à lire ?

Gurgeh
 

Gurgeh

XLDnaute Occasionnel
Re : Calculer nombre de jours + heures/minutes/secondes par rapport à 2 dates

OK, dans ce cas tu peux utiliser les formules JOUR, HEURE, MINUTE qui vont te donner le nombre respectivement de jours, heures et minutes d'une valeur.

Tu peux par exemple faire une formule comme ça, qui va te renvoyer 9j 1h 8min :

Code:
=JOUR(C1) & "j " & HEURE(C1) & "h " & MINUTE(C1) & "min"

Ensuite, tu pourras affiner avec des conditions pour ne pas afficher les jours, heures ou minutes si leur valeur est 0 :
Code:
=SI(JOUR(C1)<>0;JOUR(C1) & "j ";"")
etc.

Gurgeh
 

Modeste geedee

XLDnaute Barbatruc
Re : Calculer nombre de jours + heures/minutes/secondes par rapport à 2 dates

Bonsour®

soit format personnalisé :
j hh:mm:ss
attention ce format ne va pas au-delà de 31 jours
mais reste valable pour calculs

soit format
[h]:mm:ss (en heures au-dela de 24)
soit formule :
=ENT(B1-A1) &"j " &TEXTE(B1-A1;"hh:mm:ss")
ce résultat est un texte et n'est pas directement utilisable pour calculs
 

Discussions similaires

Statistiques des forums

Discussions
290 833
Messages
1 910 790
Membres
176 869
dernier inscrit
veusavoir
Haut Bas