Calcul du nombre de 2 dimanches consécutifs travaillés

Novice avance !?

XLDnaute Occasionnel
bonjour,

j'ai un souci de calcul de séquence de 2 dimanches consécutifs travaillés sur une année.
Sur une grille de repos où les repos sont déterminés par des lettres H, R, D je dois connaitre le nombre de séquences qui correspondent à 2 dimanches consécutifs travaillés.

Une macro vba ou une formule directe est-elle possible ?

je vous joint un fichier explicatif avec exemple pour être plus clair.

Merci par avance

Bonne journée
 

Pièces jointes

  • test_dimanches.xls
    52 KB · Affichages: 46
  • test_dimanches.xls
    52 KB · Affichages: 48
  • test_dimanches.xls
    52 KB · Affichages: 47

Dormeur74

XLDnaute Occasionnel
Re : Calcul du nombre de 2 dimanches consécutifs travaillés

Bonjour Victor21.

Si tu veux une macro qui mette les cellules en rouge, voici.
 

Pièces jointes

  • test_dimanches.xls
    61 KB · Affichages: 44
  • test_dimanches.xls
    61 KB · Affichages: 46
  • test_dimanches.xls
    61 KB · Affichages: 42

Jocelyn

XLDnaute Barbatruc
Re : Calcul du nombre de 2 dimanches consécutifs travaillés

Bonjour le Forum,
Bonjour Novice avance !?, Victor21,

Pour saluer l'ami Victor21:), et pour le fun, une formule qui n'a pas besoin des formules de la colonne F

Code:
=SOMMEPROD(($A$6:$A$365=7)*($E$6:$E$365="")*($E$13:$E$372=""))

et une autre qui n'a besoin ni de la colonne F ni de la colonne A

Code:
=SOMMEPROD((JOURSEM($D$6:$D$365;2)=7)*($E$6:$E$365="")*($E$13:$E$372=""))

Cordialement

EDIT Bonjour Dormeur74
 
Haut Bas