XL 2013 somme suite à l'ajout d'une cellule non prévue

ronaud

XLDnaute Nouveau
Bonsoir,
Je souhaiterais trouver une formule qui me permet, lors de l’insertion d’une ligne, que la somme s’effectue tt de même.
exemple 1 les 3 jules travaillent 8 heures colonne c total des heures prestées 8 heures colonnes d.
Maintenant exemple 2 les 3 jules effectuent 8 heures de travail mais je suis obligé d’ajouter 4 heures de travail à jules duplot. comment faire pour qu’en colonne d cette dernière évolue en fonction de ce que, dans le cas présent, jules duplot effectuera comme heures supplémentaires.
Je ne cherche pas une formule du type =c10+c11 ou =c10:c11 entrée manuellement mais une formule qui automatiquement dès que j insère une ligne pour heures supplémentaires à l’une des personnes elle soit prise en considération et que la somme se place en regard de son nom (D9, D10, D12). d avance un grand merci.
 

Fichiers joints

mapomme

XLDnaute Barbatruc
Bonsoir @ronaud,

Une piste dans le fichier joint. Mettre la formule suivante en D3 puis la copier vers le bas.
VB:
=SI(A3<>"";SOMME(DECALER(C3;0;0;99999;1))-SOMME(DECALER(C3;1;1;99999;1));"")
On peut y insérer des lignes et saisir les heures prestées pour un collaborateur. On a supposé qu'il n'y aura pas plus de 99 999 lignes d'heures prestées dans le tableau.
La formule n'est nécessaire que pour les lignes où figure un nom. Elle est copiable d'une ligne à l'autre en cas d'ajout d'un nouveau nom.

Voir les feuilles "Exemple 1" et "Exemple 2".
 

Fichiers joints

Dernière édition:

Discussions similaires


Haut Bas