XL 2016 SOMME PROD , NB.SI ? Somme avec plusieurs conditions.

LordYass

XLDnaute Nouveau
Bonjour les Amis,

Tout d'abord, je suis une quiche et tiens à m'excuser par avance pour mon incompétence :)

J'ai plusieurs problème à vous soumettre, j'ai tenté quelques formules mais je ne comprends pas d'où vient mon erreur :

1. Le plus facile, Je désire faire la somme de Sx, qui correspond au nom de ma Semaine, (Onglet ANALYSE colonne "C") et je tombe sur la valeur "1" alors que je m'attendais à ce qu'il me fasse la somme. PS : Je sais faire la somme en manuel mais et ce n'est pas ce que je cherche. Je désire obtenir une somme de manière automatique pour éviter le chronophage justement.

2. En E3, Je désire obtenir le résultat de 2 conditions sous "ANALYSE. C'est à dire le nombre de "DECLENCHEMENT MAINTENEUR" en Semaine 2, etc... (C2). Et ma formule ne fonctionne pas hélas.

3. En E4, idem mais cette fois-ci avec le nombre de "CLOS". Et pareil, pas de résultat

4. Normalement, je voulais créer une discussion par rapport à ce problème ci, mais je ne savais pas que j'allais rencontrer des soucis aux points 1,2 &3 :)). Donc pour ce point, et c'est le plus difficile à mon sens, c'est de déterminer le résultat de C2 (Onglet Synthèse). Je m'explique, à partir de Semaine "S2" (ANALYSE en C), j'ai des doublons de "G2R" (Onglet ANALYSE en E) et l'idée est de comptabiliser le nombre de doublons qui arrivent chaque semaine. Tout cela pour éviter un traitement déjà réalisé normalement. Ceci me permettrait de faire le ration entre Doublon et nouveaux entrants.

J'espère que j'ai été assez clair et je tiens par avance à sincèrement vous remercier pour votre aide.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2.xlsx
    83.5 KB · Affichages: 15

chris

XLDnaute Barbatruc
Bonjour

  1. C'est dénombrement pas une somme
  2. "DECLENCHEMENT MAINTENEUR" est en réalité "DECLENCHEMENT MAINTENEUR " d'où le PB
  3. Clarifie ta question
J'ai mis Analyse sous forme de tableau structuré (depuis 17 ans qu'ils existent et évitent des formules avec un nombre de lignes aléatoire...), corrigé les formules, la liste des références et les valeurs pour le 1.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2b.xlsx
    83.1 KB · Affichages: 7

LordYass

XLDnaute Nouveau
Salut Chris,

Un immense merci à toi. Tu viens de m'apprendre quelque chose :)). Même si je comprends pas pourquoi ma formule ne fonctionnait pas. J'ai cependant bien compris l'espace qui manquait pour "DECLENCHEMENT MAINTENEUR ", mais alors pourquoi pour le .3 avec "CLOS", cela ne fonctionnait pas ? (Pour mon savoir personnel :)))

Pour le point 4, je réitère ma requête :

J'ai besoin de connaître le nombre de doublon "G2R" en colonne E (G2R correspond au numéro de mon site télécom). Toutes les semaines, le Lundi, j'exporte un fichier scripté pour analyse de ces G2R. Le souci que je rencontre est le suivant :
Par ex, Nous sommes en S3 et je travaille donc sur la semaine S3 (Semaine Analyse), Je colle les résultats de mon fichier Script dans "Semaine Analyse" que je nomme S3 donc. Dans cette liste, j'ai des doublons de G2R qui étaient en S2. Et j'ai donc besoin de connaître combien de doublons G2R j'ai en S3 qui étaient présent en S2.


L'idée c'est de ne pas analyser de nouveau sur ce G2R en S3 qui est supposé être analysé en S2. Mais bon ça, c'est un autre problème :))


Exemple : Dans ANALYSE

- Filtre le 620215 : il apparait en S4 et je le retrouve de nouveau en S6.
=> J'ai besoin de le spécifier comme doublon car déjà traité en S4.


J'espère m'être mieux exprimer. Sinon pas de souci, je recommence.

Bien à toi.

Merci pour votre aide.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2b.xlsx
    79.1 KB · Affichages: 6
Dernière édition:

chris

XLDnaute Barbatruc
Bonjour

Avec une colonne supplémentaire dans la source

J'ai aussi modifié les autres formules de Synthèse car j'avais oublié de bloquer les références des colonnes
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2c.xlsx
    87.8 KB · Affichages: 10

LordYass

XLDnaute Nouveau
Salut Chris,

Merci infiniment pour ton support. Du coup j'ai recopié la Colonne Doublon et la formule sur un autre Classeur parce que j'avais oublié de te donner la MAJ du fichier. Du coup pour ton oubli, je ne sais pas du tout où je dois le corriger.

Ceci étant, j'ai un ptit souci :

- Pourquoi S8 est à 0 dans ma Synthèse alors que je suis supposé avoir des doublons cette semaine là (Semaine Analyse)?

-Autre petit inconvénient que je ne t'ai pas dis Hier, Lorsque je vais passer à S10, quand je tire tous les cellules vers la droite, les formules calculent autrement, je dois faire attention à bien cliquer sur "Recopier les valeurs sans la mise en forme" pour prise en compte (C'est ptit détail mais comme je ne suis pas seul à utiliser ce fichier, j'ai peur que d'autres ne fasse pas attention :)

Merci pour ton aide Chris.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2b.xlsx
    105.1 KB · Affichages: 4

LordYass

XLDnaute Nouveau
Salut Chris, j'ai remplacé dans la formule "Semaine d'alarmes" par "semaine d'analyse", du coup je retrouve mes petits mais j'ai un autre souci de total et que je viens de comprendre :

En filtrant sur S8 par ex, en faisant la somme des doublons, j'arrive bien à la valeur "67" de ma synthèse mais ce chiffre n'es pas bon du tout car c'est la somme global de toutes les semaines du fichier, alors que je dois avoir un nombre unitaire pour chaque semaine indépendamment des autres semaine.

J'espère que tu m'as compris :)

Merci pour ton aide précieuse.
 

LordYass

XLDnaute Nouveau
Salut Chris,

J'ai remarqué une autre erreur dans le fichier sous ANALYSE colonne "DEFAUT REPORTE", je crois que tu as décalé le menu déroulant "KEOS" et "CIRCET" au mauvais endroit. Du coup je ne sais pas le corriger.

Autre question stp :

J'ai besoin de rajouter une autre condition à "TT créé" dans ma Synthèse, la formule ci dessous me renvoie "0" :

=SOMMEPROD((Analyse[Semaine Analyse]=E$2)*(Analyse[[ACTION ]]="DECLENCHEMENT MAINTENEUR")*(Analyse[[ACTION ]]="DECLENCHEMENT D'UN AUTRE SERVICE"))

En gras ce que j'ai rajouté dans la formule et qui ne fonctionne pas.

Merci pour ton aide.
 
Dernière édition:

chris

XLDnaute Barbatruc
RE

Je n'ai absolument pas touché aux colonnes du tableau Analyse juste ajouté une colonne : reprend mon fichier posté à 15h10 : les listes déroulantes fonctionnent

Il n'y avait pas de S8 dans ce fichier : tu as du faire une fausse manip

J'ai modifié depuis ce fichier la formule Doublons et remplacé alarme par Analyse dans la formule de Synthèse

Autre petit inconvénient que je ne t'ai pas dis Hier, Lorsque je vais passer à S10, quand je tire tous les cellules vers la droite, les formules calculent autrement
Tu parles de l'onglet Synthèse ?

Je n'avais pas touché à la ligne 5 : il faut l'étirer à droite

Pour le reste je ne remarque rien d'anormal : précise ce qui ne va pas...

J'ai copié ta S8, étiré les formules dans Synthèse.

En ajoutant S8 j'ai constaté que ta validation en colonne MAINTENEUR n'était pas configurée pour toutes les lignes. Idem en colonne ACTION.
J'ai aussi corrigé cela.

A noter qu'il n'est utile de figer les volets dans un tableau structuré car quand on est dans une cellule du tableau, très bas, les titres remplacent les lettres A, B, C... des colonnes et sont donc lisibles.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2e.xlsx
    106.7 KB · Affichages: 3

LordYass

XLDnaute Nouveau
Salut Chris,

Au temps pour moi, C'était déjà comme ça même sur mon fichier Source concernant la Semaine S8. C'est un mauvais copier/coller de mon collègue :). Encore Désolé :).

Pour l'inconvénient lorsque je tire les cellules à droite pour la prise en compte des formules, je parles bien de l'onglet Synthèse. J'ai remis à Zéro les semaine S3 à S8 du tableau, fais la manip et tu remarqueras qu'en étirant les cellules, les formules changent de calcul. En soit ce n'est pas grave comme je t'ai dit, il faudra pas oublier de faire "Recopier les valeurs sans la mise en forme" pour que le calcul soit correct.


- Pour les doublons, je ne sais pas si tu as vu ma remarque plus haut ? :

"En filtrant sur S8 par ex, en faisant la somme des doublons, j'arrive bien à la valeur "67" de ma synthèse mais ce chiffre n'est pas bon du tout car c'est la somme global de toutes les semaines du fichier, alors que je dois avoir un nombre unitaire pour chaque semaine indépendamment des autres semaine."

>> Sans doute tu l'avais corrigé et je n'ai pas reçu le fichier ?


Enfin,
J'ai besoin de rajouter une autre condition à "TT créé" dans ma Synthèse, la formule ci dessous me renvoie "0" :

=SOMMEPROD((Analyse[Semaine Analyse]=E$2)*(Analyse[[ACTION ]]="DECLENCHEMENT MAINTENEUR")*(Analyse[[ACTION ]]="DECLENCHEMENT D'UN AUTRE SERVICE"))

En gras ce que j'ai rajouté dans la formule et qui ne fonctionne pas.

Merci pour ton aide Chris et désolé de t'embêter un dimanche.

Bien à toi.
 

Pièces jointes

  • Suivi_Healthchek NORD 2021v2b.xlsx
    108.2 KB · Affichages: 7

chris

XLDnaute Barbatruc
RE

J'ai remis le fichier qui effectivement n'était pas passé

Copier avec ou sans mise ne forme ne joue pas sur les formules, seulement sur le look

"J'ai remis à Zéro les semaine S3 à S8 du tableau, fais la manip et tu remarqueras qu'en étirant les cellules, les formules changent de calcul."

Tu parles de quel tableau : il faut être précis...

Pour les formules dans Synthèse ton dernier fichier ne correspond pas à mes formules de 15h10...

Edit :
=SOMMEPROD((Analyse[[Semaine Analyse]:[Semaine Analyse]]=E$2)*((Analyse[[ACTION]:[ACTION]]="DECLENCHEMENT MAINTENEUR")+(Analyse[[ACTION]:[ACTION]]="DECLENCHEMENT D'UN AUTRE SERVICE")))
 
Dernière édition:

LordYass

XLDnaute Nouveau
Salut Chris,

Oui merci, je viens de voir et en même temps, c'est ce que je t'ai dit dans le post #7, je l'avais déjà corrigé :
"Salut Chris, j'ai remplacé dans la formule "Semaine d'alarmes" par "semaine d'analyse", du coup je retrouve mes petits..."
-----------------------------------------------
Ensuite :

"J'ai remis à Zéro les semaine S3 à S8 du tableau, fais la manip et tu remarqueras qu'en étirant les cellules, les formules changent de calcul."

Tu parles de quel tableau : il faut être précis...

>>> Je parle du tableau de l'onglet Synthèse. Désolé pour mon imprécision :)
>>> Je t'ai l'aissé les semaines S3 à S8 à vides pour que tu fasses la manip
>>> Attention, la ligne 7 "Doublon G2R" par contre fonctionne bien en étirant la formule à droite

--------------------------------------------

- Pour les formules, je ne comprends pas ce que tu voulais dire, pour moi les formules sont les même que celles que tu m'as donné à 15h10, à l'exception de la correction citée au début de ce post sur le remplacement de "alarmes par "analyses".

Du coup j'ai toujours mon problème de doublon qui n'est pas corrigé. Comme je t'ai dit, il additionne le nombre de doublon alors que je voudrais le compter de manière unitaire à chaque fois qu'un doublon apparaît, sinon cela fausse le traitement du fichier.

Exemple:

Dans onglet ANALYSE, Je filtre la semaine S8 (Semaine analyse), je filtre également les doublons (de 1 à 6 qui correspond donc aux nombres de doublons d'après ta formule), je compte le nombre de lignes et normalement, je dois obtenir 31 cas (G2R pour moi) en doublons pour la semaine S8 et non "67" dans le calcul du tableau dans l'onglet Synthèse.

l'idée c'est que chaque semaine de traitement de mon fichier, je puisse voir si un G2R (ANALYSE) est revenu cette semaine là par rapport aux autres semaines. (Je ne veux donc pas additionner le nombre de fois qu'il est revenu)

Merci pour ton aide.
 

LordYass

XLDnaute Nouveau
Pour les formules dans Synthèse ton dernier fichier ne correspond pas à mes formules de 15h10...

Edit :
=SOMMEPROD((Analyse[[Semaine Analyse]:[Semaine Analyse]]=E$2)*((Analyse[[ACTION]:[ACTION]]="DECLENCHEMENT MAINTENEUR")+(Analyse[[ACTION]:[ACTION]]="DECLENCHEMENT D'UN AUTRE SERVICE")))

>> C'était un exemple de formule que je n'ai pas laissé. C'était juste pour te montrer qu'en faisant cette formule, je n'obtiens pas ce que je voulais :).

Dans onglet Synthèse, en C4 (TT créé), je voulais rajouter une condition qui doit me permettre de comptabiliser "DECLENCHEMENT MAINTENEUR" et "DECLENCHEMENT D'UN AUTRE SERVICE". Il me manque donc ce dernier dans ma formule pour comptabiliser mes TT créés de manière efficace. (Sinon, les TT avec "DECLENCHEMENT D'UN AUTRE SERVICE" ne sont pas comptabilisés).

Merci pour ta patience Chris.
J'apprécie beaucoup.
 

Statistiques des forums

Discussions
291 501
Messages
1 915 830
Membres
178 990
dernier inscrit
shadowtheone
Haut Bas