Somme dynamique sur X colonnes en fonction d'un facteur

neal

XLDnaute Junior
Bonjour,

Je cherche à faire une somme cumulée automatique en fonction du mois de l'année.

Dans le fichier en pièce jointe, je peux modifier ma date de situation en cellule C1. Ce qui est important ici est le mois, juin dans mon exemple.
Quand je change cette date, je souhaite que la formule en cellule Q4 fasse la somme du mois de janvier au mois de juin --> C4 à H4
Donc si je mets "30/09/2014" en cellule C1, je souhaite que la formule fasse la somme du mois de janvier au mois de septembre --> C4 à K4

J'ai essayé de passer par des EQUIV et INDEX sans réussite.... :confused:

Savez vous comment faire ?

Merci d'avance.
 

Fichiers joints

gosselien

XLDnaute Barbatruc
Re : Somme dynamique sur X colonnes en fonction d'un facteur

Bonsoir,

ta cellule B2 n'est pas une vraie date....mais un texte --> 31/06/2014 n'existe pas :rolleyes:
mais la formule serait ceci:
=SOMME(DECALER(B1;2;0;2;MOIS(B1)))

oups collision non voulue...
 
Dernière édition:

neal

XLDnaute Junior
Re : Somme dynamique sur X colonnes en fonction d'un facteur

Bonsoir,

ta cellule B2 n'est pas une vraie date....mais un texte --> 31/06/2014 n'existe pas :rolleyes:
mais la formule serait ceci:
=SOMME(DECALER(B1;2;0;2;MOIS(B1)))

oups collision non voulue...
Comment se sentir bête ...

Merci à tous en tout cas !!
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas