Résolu Somme de variable sans VBA

combory

XLDnaute Nouveau
Bonjour à tous,

Dans mon fichier exemple, j'ai en feuille 1 un tableau que je complète avec des variables.
La valeur de chaque variable est dans la feuille 2.
Je souhaite faire la somme mensuelle (en euro) de chaque navette, mais je patauge avec les INDEX/EQUIV/DECALER.
Contrainte :
  • pas de VBA
  • Il peut y avoir des cellules vides

Merci d'avance pour votre aide
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SOMMEPROD((Tableau1[Code]=Feuil1!$B3:$AF3)*(Tableau1[Valeur]))
copier vers le bas

JHA
 

Fichiers joints

combory

XLDnaute Nouveau
Bonjour JHA,

Merci, c'est exactement ce que je voulais.
J'étais buté sur INDEX/EQUIV. J'aurais du penser à sommeprod.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas