Résolu Si texte présent dans colonne X entre lignes 4 et 150 alors le copier

Neruda

XLDnaute Nouveau
Bonjour,

J'aimerais savoir svp s'il est possible sans macro de faire une formule pour :
  • Chercher dans la colonne B de plusieurs feuilles entre les lignes 4 et 150 les cellules avec une valeur
  • Si une valeur est présente dans la cellule alors concaténer tous les résultats dans la cellule où se trouve la formule
Avec une macro c'est ok mais je voulais savoir si c'était possible sans,

Merci
 

danielco

XLDnaute Accro
Bonjour,

1.'=SI(NB.SI(Feuil1!B4:B150;"x")+NB.SI(Feuil2!B4:B150;"x")+NB.SI(Feuil3!B4:B150;"x")...>0...
2. Je ne comprends pas. Donne un exemple.

Cordialement.

Daniel
 

Neruda

XLDnaute Nouveau
Par exemple :
J'ai 10 feuilles avec une colonne B.
Chaque cellule de cette colonne B peut être soit vide, soit contenir un commentaire textuel.
Sur ma feuille 11 je voudrais utiliser une cellule avec une formule qui concatène tous les textes rencontrés dans ces cellules de ma colonne B sur chaque feuille.
C'est pour réunir tous les commentaires des différentes cellules de la colonne B sur chacune des 10 feuilles dans une seule cellule de ma feuille 11
Est-ce que c'est possible sans macro ?
Merci
 

danielco

XLDnaute Accro
Tu ne peux pas utiliser des commentaires dans une formule. Seules les valeurs des cellules peuvent être testées et utilisées.

Daniel
 

Neruda

XLDnaute Nouveau
En fait je voudrais récupérer toutes les valeurs des cellules de la colonne B de plusieurs feuilles pour les concaténer dans une seule cellule d'une autre feuille.
 

danielco

XLDnaute Accro
Je n'avais pas lu plus loin quand j'ai vu "commentaire", mais ce n'est pas faisable non plus, à ma connaissance avec des formules.

Daniel
 

Neruda

XLDnaute Nouveau
Si je veux récupérer chaque valeur de chaque cellule de chaque colonne de chaque feuille je peux faire ça :

VB:
=CONCATENER(P01.G4;" -  ";P01.G5;" - ";P01.G6)
Mais il faudrait que je le fasse pour 100 cellules et pour chacune des 20 pages concernées,
Ne peut-on pas faire plus court comme formule, sans macro ?
Quelque chose comme : P01.G4:G100, P02.G4:G100, etc

Merci
 
Dernière édition:

danielco

XLDnaute Accro
Tu ne testes pas les cellules sont vides. De plus, tu es limité à 255 éléments et une longueur de 8192 caractères.

Daniel
 

Neruda

XLDnaute Nouveau
pas grave pour le test des cellules vides si j'arrive à remonter tout ce que je trouve dans ces colonnes,
je peux faire aussi comme ci-dessous mais ça serait trop long
VB:
=CONCATENER(P01.G4&G5&G6&G100;" -  ";P02.G4&G5&G6&G100;" - ";P03.G4&G5&G6&G100)
 

Neruda

XLDnaute Nouveau
Bonjour,

Merci, on peut le faire sur excel avec ça :
VB:
=MCONCAT(Feuil3!A1:A5)&MCONCAT(Feuil4!A1:A5)
Et sur Libre Office Calc avec :
Code:
=CONCAT(Feuil1.A1:A5)&CONCAT(Feuil2.A1:A5)
Je n'ai finalement eu besoin que de cette formule :
Code:
=CONCAT(Feuil1.A1:A5)
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas