[Résolu] pb MFC conditionnelle avec SI(ESTERREUR...

Chester Mefield

XLDnaute Nouveau
Bonjour,
Je voudrais que plusieurs cellules soient "vertes" si le taux est >12%, mais qu'elles restent sans MFC si sans valeur.
J'ai écris : =SI(ESTERREUR(D3/E3);"";(D3/E3))>12%
C'est ok si >à 12%... mais si C22 reste neutre C23-24-25 passent tout de même au vert !
Aïe aïe aïe, ça me pique un peu là !
Une correction à apporter svp ?
Merci par avance.
upload_2017-10-17_15-33-37.png
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour ChesterMefield,

Sans voir le fichier pas facile, malgré tout je suppose que si (D3/E3) est en erreur c'est parce que E3 est vide alors a tester peut être

=ET(ESTNUM(E3);D3/E3>12%)

si cela ne fonctionne pas n'hésite pas a mettre un fichier avec des données bidon

Cordialement
 

Chester Mefield

XLDnaute Nouveau
Bonjour Jocelyn,
Navré, mais ça ne va pas non plus.
Je vais tenter de faire une extraction de ce tableau pour exemple, mais il est croisé avec d'autres données..etc.
j'essaye de revenir vers vous avec ce tableau.
Merci cependant.
 

Jauster

XLDnaute Occasionnel
Bonjour le Forum,
Bonjour ChesterMefield,

Sans voir le fichier pas facile, malgré tout je suppose que si (D3/E3) est en erreur c'est parce que E3 est vide alors a tester peut être

=ET(ESTNUM(E3);D3/E3>12%)

si cela ne fonctionne pas n'hésite pas a mettre un fichier avec des données bidon

Cordialement
Hello

E3 peut aussi être un 0, dans ce cas la condition ESTNUM est respectée non ?
et avec =ET(ESTNUM(E3);E3<>0;D3/E3>12%)
 

Chester Mefield

XLDnaute Nouveau
Hello

E3 peut aussi être un 0, dans ce cas la condition ESTNUM est respectée non ?
et avec =ET(ESTNUM(E3);E3<>0;D3/E3>12%)
Bonjour Jauster,
Excellent ! En effet, la condition peut également être "0" en dehors de #N/A ou DIV/0!
Merci à vous deux pour votre aide.
Bonne soirée le Forum !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas