[Résolu] Calculs de "portion" de durée...

Kiriko

XLDnaute Occasionnel
Bonjour à tous,
Difficile d'expliquer, j'ai essayé de poster un fichier exemple probant (les "colonnes" que je souhaite renseigner automatiquement sont en vert).

L'idée est de pouvoir calculer, entre 2 heures données, quelle est la partie comprise entre 22h et 6h du matin. Par exemple, entre 21:45 et 22:08, je dois pouvoir trouver 00:08.
Mais aussi entre 05:57 et 06:12, donne 00:03,
Entre 22:48 et 23:18, donne 00:30,
Entre 05:24 et 05:38 donne 00:14
Entre 08:25 et 08:52 donne 00:00
Entre 23:51 et 25:06 donne 01:15 (j'utilise [hh]:[mm])

J'espère avoir été clair !
Merci par avance à tous ceux qui voudrons bien se pencher sur mon problème...
Cordialement,
 

Fichiers joints

Dernière édition:

Kiriko

XLDnaute Occasionnel
Re : Calculs de "portion" de durée...

Bonjour Mytå, et merci pour cette réponse plus que rapide !
Le fichier présenté dans le lien est intéressant, mais je n'arrive pas du tout à l'adapter à mon soucis....
 

ROGER2327

XLDnaute Barbatruc
Re : Calculs de "portion" de durée...

Bonjour Kiriko, Mytå


Bonjour Mytå, et merci pour cette réponse plus que rapide !
Le fichier présenté dans le lien est intéressant, mais je n'arrive pas du tout à l'adapter à mon soucis....
Essayons tout de même...

Pour commencer, est-ce que
Code:
=MAX(0;MIN(E2;1/4)-D2)+MAX(0;E2-MAX(D2;11/12))
en G2 ferait l'affaire ?
Même pour la course n° 5 ?​


ROGER2327
#5563


Mercredi 4 Pédale 139 (Saint Michet, Idéaliste - fête Suprême Quarte)
8 Ventôse An CCXX, 0,1900h - violette
2012-W09-1T00:27:21Z
 

R@chid

XLDnaute Barbatruc
Re : Calculs de "portion" de durée...

Salut @ tous,
en H2 :
=SI((B2=B1)*(C2=C1);MOD(D2-E1;1);"")
@ tirer vers le bas
Amicalement

Edit : peut etre j'ai mal compris..???:confused::confused:
 
Dernière édition:

Kiriko

XLDnaute Occasionnel
Re : Calculs de "portion" de durée...

Bonjour ROGER2327,
C'est parfait !! Merci !!!
J'ai "adapté" en I2 de la sorte :
=SI(D2<>"";SI(ET(B2=B1;C2=C1);MAX(0;MIN(D2;1/4)-E1)+MAX(0;D2-MAX(E1;11/12));"");"")
Le plus drôle, c'est que ces formules ont pointées le fait que mon remplissage "à la main" initial était éronné...
Encore Mille Merci !!
 

Fichiers joints

Kiriko

XLDnaute Occasionnel
Re : Calculs de "portion" de durée...

Bonjour Rachid_0661 et merci de ta participation active !
Peut-être ai-je mal compris ta proposition, mais ma "demande" concernait en fait les colonnes G et I (les "vertes").
Mais je prends bonne note de la simplification de ma formule en H, (je ne connaissais pas "MOD")...

Merci encore !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas