Microsoft 365 Remplissage auto de certaines cases en fonction de conditions

pilotebien

XLDnaute Nouveau
Bonjour,

Pour suivre mes différents rapports de diagnostics immobiliers, je me suis crée un tableau sous excel.
Les diags sont : amiante, DAPP, DTA, DPE, ELEC, GAZ, Termites, Plomb, Radon
Bien sur chacun a une date de validité différente, des contrôles réguliers etc.
Mon idée est d'automatiser suite à la saisie d'une date et d'un etat de remplir un maximum de case.
J4ai expliqué mon besoin dans le fichier joint.
Merci de votre aide.
 

Fichiers joints

Rouge

XLDnaute Occasionnel
Bonjour,

Bizarre, chez vous 01/01/2018 + 3 ans = 31/12/2021, à 1 jour près, cela fait 4 ans

Pour l'amiante:
en E6 et à tirer vers le bas:
VB:
=SI(Feuil1!$D6="OUI";MOIS.DECALER(Feuil1!$C6;36)-1;"NC")
Pour la MFC en E6 et à appliquer à l'ensemble de la colonne E:

saisissez les formules dans l'ordre qui suit,
d'abord pour la couleur orange
VB:
=ET($D6="OUI";$F6<>"";MOIS.DECALER($E6;6)>$F6)
puis pour la couleur rouge
VB:
=ET($D6="OUI";$F6<>"";MOIS.DECALER($E6;3)>$F6)
Répéter les formules et les MFC pour les autres DAPP, DTA ,etc...

Cdlt
 

pilotebien

XLDnaute Nouveau
Bonjour.
Merci de votre retour.
Oui, il y a erreur dans les dates. :rolleyes:
Votre aide est précieuse et répond correctement a mes attentes.
Cordialement,
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas