Remplir un tableau en Auto ! Quelle formule utlisé ?

starz

XLDnaute Occasionnel
Bonjour,
J'ai un tableau à remplir en automatique mais je ne sais pas qu'elle formule utlisé.

En Colonne Q la liste des prix par référence (colonne H)
Dans la table (A3:G15)
Si F9=6 ALORS
dans la table (K3:p15) O9=Q8
(le niveau 6 correspond au prix 6 , le niveau 5 correspond au prix 5 ainsi de suite, ça c'est la règle)

Je joins une pièce jointe car plus facile q'une explication

merci d'avance pour votre aide
 

Fichiers joints

Tibo

XLDnaute Barbatruc
Re : Remplir un tableau en Auto ! Quelle formule utlisé ?

Bonjour,

Une tentative avec cette formule en K3 :

Code:
=SI(COLONNES($A:B)=SOMME($A3:$G3);$Q3;"")
à recopier vers le bas et vers la droite

Je te laisse tester

@+
 

mromain

XLDnaute Barbatruc
Re : Remplir un tableau en Auto ! Quelle formule utlisé ?

Bonjour,

Voici un essai :
Saisir cette formule en K3 et la tirer vers le bas et vers la droite :
Code:
=SI(DROITE(K$2)*1=SOMMEPROD(($A3:$G3<>"")*$A$2:$G$2);$Q3;"")
Edit: salut Tibo
a+
 

starz

XLDnaute Occasionnel
Re : Remplir un tableau en Auto ! Quelle formule utlisé ?

encore merci à tous les 2 !

:D bonne journée et bon week-end
 

hoerwind

XLDnaute Barbatruc
Re : Remplir un tableau en Auto ! Quelle formule utlisé ?

Bonjour, salut Tibo et mromain,

Autre possibilité :

Mettre le tableau K3:p15 au format _-* # ##0.00\ €_-;;
En K3 :
Code:
=(COLONNE()-9=SOMME($A3:$G3))*$Q3
formule à copier vers le bas et vers la droite.

Edition :
Les sept premières colonnes peuvent être réduites à une seule, ce qui simplifie la saisie des niveaux et raccourcit la formule.
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas