recherche de formule

boblenormand

XLDnaute Nouveau
si je prend la case C2 10h05mn moins la case B2: 10h10 mns. Cela fais 00h05 mns . Donc en résumant si la somme de ces deux cases est superieur à 00h01 mns il faut rajouter 1heure.
En claire = SI((C2-B2)>0.01; on rajoute 1 heure ........) je n'arrive pas à finaliser.
Merci pour vos réponses
Thierry
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Tu as mis ton message sur le salon XLD donc peu de réponse car il y a le forum "Excel" pour cela.

Voir les deux formules dans le fichier joint avec ce que je comprends.
VB:
=SI(C2<B2;0;SI((C2-B2)>"00:01"*1;"01:00"*1;0))
ou
Code:
=SI(MAX(0;C2-B2)>"00:01"*1;"01:00"*1;0)
JHA
 

Fichiers joints

boblenormand

XLDnaute Nouveau
Bonjour à tous,

Tu as mis ton message sur le salon XLD donc peu de réponse car il y a le forum "Excel" pour cela.

Voir les deux formules dans le fichier joint avec ce que je comprends.
VB:
=SI(C2<B2;0;SI((C2-B2)>"00:01"*1;"01:00"*1;0))
ou
Code:
=SI(MAX(0;C2-B2)>"00:01"*1;"01:00"*1;0)
JHA
Bonjour à tous,

Tu as mis ton message sur le salon XLD donc peu de réponse car il y a le forum "Excel" pour cela.

Voir les deux formules dans le fichier joint avec ce que je comprends.
VB:
=SI(C2<B2;0;SI((C2-B2)>"00:01"*1;"01:00"*1;0))
ou
Code:
=SI(MAX(0;C2-B2)>"00:01"*1;"01:00"*1;0)
JHA
merci c'est cool j'ai du mal m'exprimer , en fait je voualis que le résulat soit : si dans ce cas dès la premiere minute se rajoute une heure .
toute heure entamée euivaut à 1 heure de plus . exemple: 0h05 = 1h05 ou 1h05 =2h05
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

La formule te donne déjà "01:00" si supérieur à "00:01"

En rajoutant le signe "=", la formule donnera "01:00" dès "00:01"

VB:
=SI(MAX(0;C2-B2)>="00:01"*1;"01:00"*1;0)
JHA
 

boblenormand

XLDnaute Nouveau
Bonjour à tous,

La formule te donne déjà "01:00" si supérieur à "00:01"

En rajoutant le signe "=", la formule donnera "01:00" dès "00:01"

VB:
=SI(MAX(0;C2-B2)>="00:01"*1;"01:00"*1;0)
JHA
En fait il ne faut pas arrondir à 1h il faut simplement rajouter à cette minute et à partir de la première minute 1 h . dans ce cas ce serra au total 1h01 Si la somme des deux cases est de 13 minute il faudra que le résultat soit de 1h13 . Dans le cas si la somme des deux case est de 1h passée au moin de 1 minute 1 h doit également se rajouter. soit 2h01 etc etc . En tout cas merci de te décarcasser pour moi
 

ya_v_ka

XLDnaute Impliqué
On va commencer par bonjour !

Ensuite on est pas sur le bon forum !

Continuons par quelques incompréhensions :
1. 10:05 - 10:10 = -0:05 et non pas 0:05 !
2. La somme de 10:10 et 10:05 donne 20:15...
3. Pourquoi faut-il rajouter 1 heure ?
4. A quoi devait correspondre le 0.01 ?

Et pour finir… et là on se rejoint enfin… un ptit merci et des salutations...

Amicalement

Ya_v

Bin voilà que le fichier s'envoie 24hoo après sa rédaction... donc désolé !
 

Discussions similaires


Haut Bas