Recherche à partir d'un critère par ligne et par colonnes

mamatt62

XLDnaute Junior
Bonjour,

j'aimerai créer uen formule sur la base d'un Index Equiv, qui chercherait un critère par ligne et les autres par colonnes est ce possible ?

Pour visualiser ma demande je vous ai joint un fichier explicatif.

C'est un fichier simplifié mais l'idée est là.

A votre disposition pour en discuter

Merci à vous.
 

Fichiers joints

phlaurent55

XLDnaute Barbatruc
Re : Recherche à partir d'un critère par ligne et par colonnes

Bonjour mamatt,

avec cette formule:

=INDEX(B4:E10;EQUIV(J3;A4:A10;0);EQUIV(CONCATENER(H3;" ";;I3);B3:E3;0))

Attention aux mots avec ou sans majuscules

à+
Philippe
 

Fichiers joints

Dernière édition:

JCGL

XLDnaute Barbatruc
Re : Recherche à partir d'un critère par ligne et par colonnes

Bonjour à tous,
Salut Philippe,

Un SOMMEPROD() avec les mêmes réserves que PhLaurent55 : Attention aux espaces superflues et à la casse...

Code:
=SOMMEPROD(($B$3:$E$3=$K$5)*($A$4:$A$10=J3)*$B$4:$E$10)
A++ l'ami et bises à Abdou...
A + à tous
 

mamatt62

XLDnaute Junior
Re : Recherche à partir d'un critère par ligne et par colonnes

Merci à tous les deux pour vos réponses rapides je vais tenter de faire fonctionner ceci ce week-end.

Je vous dirai si ca fonctionne.

Merci encore bonne journée et bon match pour ce soir si vous êtes amateur de foot.

mamatt
 

mamatt62

XLDnaute Junior
Re : Recherche à partir d'un critère par ligne et par colonnes

Bonjour à tous les deux,

j'ai essayé les deux formules et je n'arrive pas à la faire fonctionner.

Cela fonctionne t'il avec des infos dans d'autres pages ?

Avez vous une idée d'où peux provenir l'erreur ?

Merci pour votre aide.
 

phlaurent55

XLDnaute Barbatruc
Re : Recherche à partir d'un critère par ligne et par colonnes

Re,
Cela fonctionne t'il avec des infos dans d'autres pages ?
Bien sûr, mais dans les formules il faut faire référence à la feuille sur laquelle se trouvent les données
Pour visualiser ma demande je vous ai joint un fichier explicatif.

C'est un fichier simplifié mais l'idée est là.

A votre disposition pour en discuter
j'ai essayé les deux formules et je n'arrive pas à la faire fonctionner.
si la configuration des feuilles est différente par rapport au fichier joint à la question, ça échappe à ma boule de cristal

pourrais-tu mettre ton fichier (sans données confidentielles en pièce jointe)

à+
Philippe
 

mamatt62

XLDnaute Junior
Re : Recherche à partir d'un critère par ligne et par colonnes

Cela fonctionne merci à vous deux merci pour votre aide.
 

Discussions similaires


Haut Bas